Jump to content

BIOS RAID not Detected During Installation

Kienja Kenobi

2 posts in this topic

Recommended Posts

I am attempting to install Macintosh OSX onto my PC without much success.


Here is my hardware:

PC: Sager NP9262 Laptop

Motherboard: Clevo D900C

CPU: Intel Q6700 Core2 Quad 2.66Ghz


HD's: 3x SATA hard drives connected with Intel ICH8R SATA RAID Controller (BIOS RAID)

GPU: NVIDIA Geforce 8800M GTX

Intel 82801 PCI Bridge

Ethernet: Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC

Intel ICH8 Family USB Universal Host Controller


Here is my problem and the things I have done to attempt to fix it:


First I tried the iATKOS 4.0i DVD. I verified the MD5 sum of the download, burned the disk at 4x, and then verified that the burned DVD matched the file on my computer. Both were successes. The boot procedure of iATKOS worked perfectly. As the installer finished initializing and I prepared to partition my drive, I went to the Disk Utility only to find that my RAID set-up could not be detected. The three drives that compose my RAID 0 were listed, but there was no entry for the actual RAID connection between these three drives. Therefore, I was unable to continue with the installation.


I thought perhaps this was a matter of the slimmed-down iATKOS DVD not having enough drivers, so I thought going with a larger distribution, Kalyway, might fix this problem. I went through all of the same steps as I did with iATKOS and everything was a successful again up until the point of the drive partitioning. Again, the three individual drives were detected, but no RAID was detected.


This is baffling because the Kalyway official documentation states that "All ICH supported." It is indeed talking about Intel ICHx controllers, right?


At this point I thought it might be possible for me to install Macintosh OSX onto my external hard drive, then tinker with that installation until I could get it to detect my RAID setup, and then move the installation to my internal RAID. This, too, did not work. My external hard drive was not detected by either iATKOS or Kalyway. This would make it seem perhaps it is also not communicating with my USB ports. Perhaps this is because it is also controlled by Intel ICH8 (As you can see above from my hardware list).


Finally, the last thing I tried was to add the Intel ICHx drivers found here: http://forum.insanelymac.com/index.php?sho...p;hl=Intel+RAID, to the Kalyway DVD. When I first looked at the command I thought it was something that could be accomplished on Linux, but after trying the command once it became very clear it is a Macintosh-only command. It calls upon hdiutil and kextcache. I do not not have access to a Macintosh computer where I could properly execute the command to integrate that driver into the Kalyway DVD iso.


Therefore, I am back to the beginning and have a simple question: How can I get the installer to detect my RAID setup so that I can install the operating system?


Yes, I have indeed seen this article: http://forum.insanelymac.com/index.php?showtopic=76404, and I am quite positive it is not relative to my situation. This deals with creating a software RAID setup after Macintosh has been successfully installed.


My BIOS have a meager set of customization options. The only option I can find (Out of the seven available options) that remotely relates to hard drives is the SATA setting, which is currently set to RAID. When considering that I am indeed using RAID, I do not think I want to change this to another setting.


I have attempted going through the DVD boot procedure with the verbose flag to see if I can find any relevant error messages. The only thing I have seen is a one line message when I am booting Kalyway which is the last message I see before the graphical user interface takes over:


"Sep 16 02:15:30 localhost diskarbitrationd [44]: CoreRAID Server not responding"


Immense thanks for any help and consideration,



Although at this point it is not working for me, I must thank the developers of OSx86 and the administrators of InsanelyMac for this opportunity to use Macintosh on a PC. It is simply a fantastic idea.

Link to comment
Share on other sites

  • 3 weeks later...

I believe I have the answer to my own question:


BIOS RAID with the Intel ICHx chipsets simply does not work with Macintosh at this point, and, judging by the amount of interest in this matter, it is going to stay like this for a long time. Perhaps support for this will never reach Macintosh. Support for it was difficult enough to find for Linux and BSD and exists for Windows only because Intel itself created the necessary drivers (Though these drivers are not present on Windows installation disks).


The solution is to get a hardware RAID controller than can work independantly of the operating system or to use Macintosh's own software RAID function. Without a doubt, I highly recommend hardware RAID. It is much less hassle, it is faster, and it will work regardless of what operating system you decide to run on your system (Which should be the case for all hardware).

Link to comment
Share on other sites


  • Create New...