Jump to content

HP DV2040TX


holastickboy
 Share

3 posts in this topic

Recommended Posts

Hi all, firstly I would like to thank those who have done so much work to get everything working on the osx86. I have aquired the kalyway 10.5.1 dvd and have installed it on two computers, an hp pavillion a6340a and a hp notebook dv2040tx. The a6340a just refuses to work, and although I can get it to install and boot to a certain point, it just hangs on boot time. Anyway, the main reason why I am writing this post is the dv2040tx laptop installed and runs perfectly, with no command line stuff or anything. The video card and everything works nicely, except I have no ethernet and the sound is bad. The ethernet is aparently an Intel Pro, but I am finding it hard to find exactly what model it is, same with the sound card. I installed the sound drivers for the Intel HDA, but there is no sound from my speakers, and the headphone works, but the sound is very skippy and it is horrible sounding. Can anyone suggest how I may find my specific model numbers for my ethernet and sound? I have gone to the official HP website, and it is vague, just says Intel HDA and Intel Pro

Link to comment
Share on other sites

  • 2 weeks later...
have the same model... also need assistance with the sound card and ethernet card.

were you able to get the standard wifi card working or did you replace it?

 

I have discovered the wifi card is iwi3945 and there is a driver for this in the works. i have tried a MacBook mini-PCIe card and non-HP cards are blocked by BIOS. there are also ways around that but i would rather get the original card working with a driver to save bricking the machine.

 

any further thoughts?

Link to comment
Share on other sites

 Share

×
×
  • Create New...