Jump to content

Installing 10.5.4 : Some leasson learnt


1 post in this topic

Recommended Posts

Dear All,


Thanks a lot for support. I could install and upgrade to 10.5.4. Also I was able to Install iPhoneSDK and execute first sample program.


During Installation I found some issues and thought will share so that someone else can benefit (if required)


This is what I did


1. Downloaded Kalyway 10.5.2

2. Downloaded Chameleon-1.0.11-JMicron patch -- this is for ensure the plist problem is removed. Apply this patch on the ISO file

3. Burnt into DVD

4. Boot using this DVD and install. I do have dual boot. Some teething problems were there and the same is explanined below

5. Download Kalyway 10.5.3 -- The Apple site download was failing for me (both 10.5.3 and 10.5.4)

6. Restart with update -v

7. Download 10.5.4 from apple site

8. Upgrade 10.5.4

9. On re-boot it did not work. Gave some warning but could see it -- so fast (even with F8). Based on this forum's help download v4.2 (http://forum.insanelymac.com/index.php?showtopic=86167).

Re-booted using DVD (Kalyway 10.5.2 ). During the install process choose Terminal and Just copied the mach_kernel from the v4.2/Kernel directory to "/". Reset the compture remove the DVD and restart. Worked like a gem

10. Downloaded iPhoneSDK and installed. Now it works like gem


**** For new CPU/Motherboard u should be able to work with Vanilla 10.5.4 itself.


My Machine

CPU : Pentium 4, 3066Mz

CPU Alias : Prescott

CPU Setting : G1

Instruction Set : X86, x86-64, mmx, SSE, SSE2, SSE3

Display Chip : ATI Radeon Xpress 200

RAM : 512MB


Motherboard ID : GC11020M.86A.1058.2006.0330.1109


Motherboard Name : Unknown


Harddisk : Driver Description ST380211AS (Configure SATA as IDE)

ATA/IDE Mode : Enhanced


1. SAM Multimedia: READ or WIRTE failed, SENSE_KEY = 0x05, ASC = 0x64, ASCQ = 0x00

disk1s2: unsupported mode


This simply means a bad DVD, normally due to Write error. Suggestions

1. Write using new DVD writers. I had 5 years old one and wasted many DVDs

2. Write using lower Speed (2x)

3. Please ensure to select Verify option. This will atleast give early warning about read error -- When u get error no other options retry (or get new DVD writer from some where and make a copy)

4. In case u did not use Verify to check whether DVD is good or not - Try making a DVD copy (into Image) using ur Buring Software


2. Unable to copy files. Check the Media file or contact Apple (I forgot the exact error message)

This was just because of not formatting the partition as "MacOS Journaled". Using disk util I tried but the partition could not re-formatted for "MacOS Journaled". I had WinXP in my box and created additional partition to install MacOS. I just used DiskUtility and selected the entire Harddisk and re-partitioned using DiskUtility. This meant I had to re-install WinXP. But all worked prefectly


3. 1586 Sep 1 15:39:03 localhost root[1257]: Running ifcstart

1586 Sep 1 15:39:08 localhost root[1260]: update_dyld_shared_cache


This was interesting error. I was stuck on this for quite for some time. I had 512MB. For some reason while booting it shows 456MB only. Any case after getting update_dyld_shared_cache error for many times -- I decided to upgrade my Memory. Got a 1GB card and retryed. It worked like a gem


4. Upgrade to 10.5.4

First and foremost 10.5.3 combo and 10.5.4 combo downloaded from Apple site did not work. It just hanged.


1. Download Kalyway 10.5.3 Comob from some torrent site and installed with out any issue

2. Re-booted with update -v

3. Appled Appel website 10.5.4 upgrade. The upgrade was sucessful but fails while re-booting. This later attributed to my Machine CPU Pentium 4. Did as per the above instruction (Step 9)



Please note

I did the exact same steps 1-10 (except step 9) on following machine and it works like a gem


a. Laptop T61 Lenovo (IBM)

b. 2 GB

c. External USB Harddisk -- the entire MacOS + iPhone SDK is installed in the external disk only. My laptop has single harddisk partition (C drive only) running WinXP.

This has ensured that I need not screw my Office Laptop at the same time don't need to fight for time slot with family for house PC


Once again thanks a lot for all the support

Link to comment
Share on other sites


  • Create New...