Jump to content

atheros 5005g not working - might be pci problem?


1 post in this topic

Recommended Posts



I installed retail Mac OS X using boot-132 by kabyl 2 days ago,

and I've been trying to make my wireless network card working.

I have tried every single method that has been discussed but still can't get through ;(


So, the last thing I suspect is PCI recognition.

I have no other PCI devices, so I couldn't prove this issue, but I think this is apparently persuasive

since this network actually worked in kalyway 10.5.2, and iATKOSi4(4i?) 10.5.4 which are hacked ones.


Well the miserable thing going on me is that as soon as I installed iATKOS the network was JUST RECOGNISED

directly and I thought that this would have to work if I copy those io80211family.kext and ionetworkingfamily.kext (network drivers)

but didn't work. I even tried replacing networkinterfaces.plist which contains en1 things.. and still no getting through..


In Kalyway 10.5.2, I needed to do those known kext work and additional networkinterfaces.plist work in order to make

my girl working but as soon as I patched it to 10.5.3 network had gone out.


So my opinion is that, somehow kexts beyond 10.5.3 may contain some PCI patches(upgrades) which bothers pre-existing

PCIs working. In case of iATKOS 10.5.4, PCIs were already fixed by who made it so that compatibility is the best.

(If the team reads this, please correct it.. :()


Anyway I didnt open this thread to discuss this issue.. actually what I want is YOU who uses AR5005 in 10.5.4 finely..

Link to comment
Share on other sites


  • Create New...