Jump to content

Some questions about the GMA950 kext. (Solved)


5 posts in this topic

Recommended Posts

I did a install of Kalyway 10.5.1 DVD a couple of weeks ago. It all went good and everything worked fine. Except for the sound, but that's not very important. Anyway. then i did a update with the Kalyway 10.5.2 Combo Updater, and it worked pretty good, still no sound tho.


Then last week i updated to 10.5.3 with Kalyway Combo updater and my graphics started to mess, i got the blue screen on start with no cursor; plugged in a external display and downloaded some kexts and the laptop-display worked again. Updated to 10.5.4 with Apple Updater. But i couldn't change the desktop background or show any animations like switching Spaces or something, i started to research and find out that the QE wasn't supported. But it was when i had 10.5.1, Anyway. I tried out many different kext and find the darwin950-kexts, installed those and i could change background atleast, and show some graphics (the spaces-thing, and dashboard), even change resolution (even if it's to 800x600 and 640x480).

But QE still isn't supported, so iWork won't work, or the animations at Dashboard, or the Transculent menu bar.


Now when i looking at the kext that's loaded the AppleIntelGMA950.kext isn't there. Only the AppleIntelInternalFrambuffer.kext. I wonder why the GMA950.kext not loading at boot, yes. It's in the Extensions-folde, and if someone got QE/CI to work with this update and card. Or other advices.

Those files i got is:








The only one that's loaded is AppleIntelIntegratedFramebuffer.kext.


And, yes. I've search. ALOT! yeah, my board is 945GM.


Thanks! If you got any questions about kext-versions or something, ask! :)


Edit: My Device-ID is 0x27a2. I did realize that it matters. :(


Link to comment
Share on other sites

Tack för alla svaren! Det var en grej jag hade slarvat med bara, hade tydligen kvar -x som kernel flag i com.apple.boot.plist. När jag tog bort den bootade systemet avsevärt mycket snabbare och QE/CI fungerar perfekt! Nu är det bara Dual-monitor problemet som kvarstår.


In english, i had left the -x flag in com.apple.boot.plist from another problem (my bad), i cleared the Kernel Flag string and my system did boot alot faster + QE/CI works perfect! Check that if you got the 950GMA! Now, the only problem left is Dual-Monitor support. Got alot of artifacts when connecting the external display and disable the on-board. Well, time to google!



Link to comment
Share on other sites


  • Create New...