Jump to content

itunes rented movies - will not play


1 post in this topic

Recommended Posts

Hi there, I am running an AMD 5000 X2 2.62 Dual core system, with LawlessPPC 10.5.4 cd. It works great for almost every thing as far as I can see...except for once small issue. I can play music with itunes but I cannot, for the life of me, play a rented movie. The computer authorized fine, the movie donloads perfectly, and when I go to play it, itunes says it's playing...but no movie windows appears, it just stays on the rented movie screen, no moniplayer, nothing...I tried:


- Setting the miniplayer to always stay on top

- I made sure itunes is set to open the movie in a seperate window

I tried reinstalled itunes (I even fully removed it, and patched it with marvin patcher just to be safe) Everything world excvept the movie rentals...


Hasd anyone else had this problem? Can you point me in the right direction of you got it to work.


My specs:


-LawlessPPC 10.5.4 AMD install

- AMD X2 5000+ 2.62 Dual Core Black Edition

- 4GB ram

- 500 GB HDD

- Nvidia Geforce 6800- ALC 888 sound

- 9.4.0 Vanilla Kernal


Every seems to work great except for itunes rented movies.


Thanks in advance for you help!

Link to comment
Share on other sites


  • Create New...