Jump to content

Fix for the "classic cursor on boot" problem


1 post in this topic

Recommended Posts

Just to warn you, for all I know this could not affect anyone else in the entire world. (I've never seen this problem on these forums. However, I do NOT frequent these forums and thus haven't seen MOST things here) However, I have two machines each with TOTALLY DIFFERENT SPECS (The ONLY thing they have in common is they're both not Vanilla, are both Intel boxes, and both have (different) GeForce cards). Upon boot, they have a classic-style mouse pointer until you change the resolution once. A quick and easy fix as one can easily imagine is to change the monitor resolution once and then change it back to whichever you need. This quickly gets annoying, however, even with the Displays menu bar item. (Besides, it takes up room in my menu bar and I only use it once per boot.)



I have written a simple AppleScript using cscreen (command-line screen-mode-manipulation binary, no longer maintained and the author's site is gone. For all I know it may not even be a universal binary, but it works and it works fast so I'm happy.) which will save what resolution you currently are set to, set your resolution to 800x600 (if for some odd reason 800x600 doesn't show up in your Display section in System Preferences, you HAVE to open this up in Script Editor and edit the resolution in there to one that you do have AND don't boot with.) and set it back to the original one. This fixes the mouse cursor bug fast and easy.



Simply download and unzip switchres.zip and then drag it into Login Items in the Accounts section of System Preferences. It will look something like this: 76c834df86321080428be414aeaf23d7.png


To test it out, do the obvious: reboot. It should quickly switch resolutions to and from 800x600 and then you'll have your shadowed mouse pointer.

Link to comment
Share on other sites


  • Create New...