Jump to content

Kalyway 10.5.2 to 10.5.4 on X38 With RAID/AHCI


1 post in this topic

Recommended Posts

Having now successfully got 10.5.4 up, I thought I'd document the process on the off-chance that other might find it useful.


My hardware is a Asus Maximus Formula, which is X38 based. The ICH9 is set for RAID mode, as I'm running a RAID drive for Windows. OS X is on a separate SATA drive, also connected to the ICH9, but not as part of the RAID array.


After a number of false starts, this is the process that I folowed:


First, do a clean install from the Kalyway 10.5.2 ISO, selecting whatever graphics support you need. The ASUS Maximus will run with default options.


Secondly, install the Kalyway 10.5.3 ComboUpdate, but DON"T reboot yet. (Installing the ComboUpdate is two steps, first the update itself, then the Kernel. I Used the vanilla Kernel). If you reboot now, you will get the dreaded "waiting for root" error. The reason for this error is that the AppleAHCIPort and the IOAHCIFamily kexts that you just installed no longer have ICH8/ICH9 RAID/AHCI support in them.


The solution to this problem is in this thread. However, you will find that you can't follow the installation instructions provided, because you can't sudo - the system no longer recognizes your password because of the half-complete update. At this point, the system is in difficult state - you can't sudo, but unless you you replace the kexts with those in the thread, you can't reboot either. What I found was is that you can replace the kexts by following this procedure:


1. Open the two kexts in System/Library/Extensions using Finder and "Show Package Contents". Then drag and drop the new info.plist files from the thread above into position, replacing the existing info.plists. Finder will ask for Authority, but will do the replace


2. Then use Disk Utility to repair permissions (you also can't chown).


3. Finally, delete /System/Library/Extensions.mkext


Once you have done this, you can reboot. As soon as the Darwin options prompt comes up, hit any key, and then enter "update -f -v" (without the quotation marks). Note the -f; this rebuilds the cache. Darwin will then think a bit, and then reboot the system. When it does that, just let the reboot happen. If all's gone well, you now have a working 10.5.3 system with RAID/HCI support.


The final step is to upgrade to 10.5.4 - just use the Apple upgrade system to do that.


End result of this procedure for me was a working 10.5.4 system. All I had to do in addition was to install Taruga Rev 4 to get sound working (output only - the Mic still doesn't work)


Note that there may be other ways to get the kexts in place - via the terminal from the install disk, or perhaps doing the update as root. But the above worked for me.

Link to comment
Share on other sites


  • Create New...