Jump to content

Vostro 1510 Leopard Install Experience

5 posts in this topic

Recommended Posts

Ok, I felt I'd share my experience installing leopard on a friends dell vostro 1510. I have to say so far I'm pretty amazed. I've got a mostly working hackintosh, at less than $500.


Laptop Specs:

Intel Gma x3100

1gb ddr2 (upgraded to 4gb)

1.8ghz core 2 duo

dual booting xp and leopard via chain0 method


Installed with Kalyway 10.5.2 w/sleep kernel


What doesn't work:


wifi- broadcom 4311, dev id 4315 (there is a guide by a french guy to add the dev id to the kext, but I can't get it to work right? If anybody can help that'd be great, the 4311 enabler script causes it to no longer boot to leopard.)


intermittent usb- usually requires restart after plugging in a new device


Kalyway 10.5.2 -> 10.5.4 update breaks onboard keyboard and trackpad (there is a fix which replaces the keyboard and mouse with the old kext from 10.5.2, you would need an external mouse though so I haven't been able to try it. Search "[Mac OSx86] PS/2 Fix Installer for OS X 10.5.4 " to find it) (I haven't tried going from 10.5.2-> 10.5.3 -> 10.5.4)


sd slot does not work, just use an external usb adapter


Track Pad Two Finger Scroll, there may be a program that would do the near same with a keyboard/ trackpad combo button



What works:

Everything else I think?


ethernet, firewire (not fully tested)


gma x3100 oob no problems QE-CI, and it doesn't require an external monitor to install :wacko:


sound- you must use the "alc268fix", install version 2, following the instructions, sound and shutdown worked for me after reboot


Internal keyboard and mouse prior to updates


not tested: webcam? (I didn't think it had one till I read a review), dvd/cd burning (it reads them fine, so I assume it works), internal mic's? (didn't know about them until reading another review), cardbus (I didn't have any cards on hand, but I assume it works)


If you are in possession of one of these feel free to fill me in on any information I may be missing, or any heads up's I should inform people about. The main thing I noticed is the usb, updates, and wifi don't work quite like how they were advertised by some other posters.




PS: My bad for not posting this in the leopard section, I haven't posted in a quite a while, lol.

Link to comment
Share on other sites

  • 3 weeks later...

I'm a complete N00B, with a streak of beginners luck... Thank you for this post! Now perhaps my sound will work... will try.

I just got a Vostro 1510 also, did the same Kalyway 10.5.2 install. My mom's using it now, and I'm hoping that I'll be able to get her a fully functional Hacintosh... (although my motives are entirely selfish: I dont want to always be oncall to explain the latest windows bug or Ubuntu discrepency! Although I personally really like Ubuntu, it's not quite reached the usable level for those only partially computer-literate users!)


webcam works out of the box, and MacOS at least sees the firewire and bluetooth.

ethernet: Havent yet tested, will post back when I do.

Keyboard works fine.

Eject button or eject key combination does not work. MacOS soft Ejects if we drag the CD or DVD to the trash.

Touchpad works only minimaly; taptoclick does not work, and the right click also does not work.

I have not tested USB yet. EDIT: just plugged in my USB stick, and it worked fine. This is the Vanilla Kernel. Will try to test in Sleep Kernel.

Sleep does not work with the Vanilla Kernel; I will try the sleep kernel next.

Have not tried the card reader yet, although dissapointed to see that it didnt work for you.


Other than that, I have noticed some SOFTWARE problems:

double-clicking to open the image preview works, but clicking next does nothing (nor Command+Left Arrow nor Go>Next menu) Perhaps this is just a problem with the build? Will updating help?



The last MacOS I've used was 7... back in the days of the Performa. Now I have a few questions:

I used to be able to move extensions from enabled to disabled folders inside system folder to enable or disable them on next restart. Alternatively there was a control panel called "Extension Manager". (I must say that I'm a little dissapointed with the extreme limitations in the current control panel, but anyway.) Now, I understand that the kexts are the same as those previous extensions... can I move them in the same way?



How can I enable/disable a kext at will?

Is an install the only way?


I found a site where A guy boasts of having his 1510 completely running on OSX:


but doesn't say how he did it... Any Ideas?

Grateful for any help,


Swift Arrow

Link to comment
Share on other sites

  • 3 months later...

My experience with Vostro 1510:



Intel Core2Duo T8100 2.1Ghz

4Gb DDR2 ram

Nvidia 8400GS

Ethernet:Realtek RTL8168C/8111C

Wifi: Intel 3945

Realtek ALC268 Sound Controller


I installed Kalyway 10.5.2 with vanilla kernel chosing Nvinject256 as video driver, after run Dell post installer, and it works fine:


Hardware Overview:


Model Name: Mac

Model Identifier: Vostro1510

Processor Speed: 2.00 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache: 3 MB

Memory: 4 GB

Bus Speed: 760 MHz

Boot ROM Version: MBP41.00C1.B00

Serial Number: Dell Inc.


Wireless will not work, there's no driver for 3945

Ethernet works fine.

Sound works using ALC268installer2 and after ALC268.mpkg but Shutdown and sleep doesn't work, restart makes shutdown. It sounds but first two, three seconds the sounds crash and after it sound good, sometimes making clicks when i open an application. I have not tested mic yet. I've tried with a Behringer UCA200 (usb-rca converter) and it doesn't work at all, sounds half second and stop 3.

Nvidia it seems to work good but not DVI output, i've tried NVCAP edit and the system never start again. (black screen)

USB works fine.

Firewire it seems to work and (sometimes) recognaizes a sony dv camera but i couldn't capture any video. Not tested with other device.

Memory: it recognizes DDR2 SDRAM 800Mhz and mine is 667MHz Should be this a problem?


Any idea for DVI output, sound (external card?), shutdown and firewire?


Thanks to everyone that make osx86 posible.

Link to comment
Share on other sites

  • 2 years later...

I must be doing something wrong


I have the same machine (AFIK) and I have installed Snow Leopard 10.6.3 without any real issues using Empire EFI. Even updated to 10.6.7 without any drama.


Runs brilliantly except:


1. Have to use an external monitor, keyboard and mouse. The onboard LCD shows half the screen. The rest being shifted off to the left


2. No wireless


3. No sound


Haven't bothered to test laptop keyboard and trackpad as opening the lid causes the display to corrupt.


I've tried the kexts from various guides on this site, but everything I add just causes a panic. I have to boot in safe mode and delete whatever kexts I installed before the crash.


All very frustrating as I'm so close to getting it working, and lots of people seem to have succeeded in getting this laptop to work.


If anyone has any advice on this I'd be very happy to hear it.

Link to comment
Share on other sites


  • Create New...