Jump to content

Problems installing EFI on Intel D945GCNL mobo


2 posts in this topic

Recommended Posts

Hello all. I'm having a problem booting after installing EFI. To simplify this, I'm not even worried about loading the OS at this point. I would just like to see the "system configuration file com.apple.boot.plist not found" message. All I'm getting now is a blinking cursor in the top left corner of the screen. I suppose this is some improvement over where I started, since I was getting a "no boot device found" message.


Here's my configuration:

Motherboard: Intel D945GCNL

Processor: E4600 C2D 2.4GHz

Memory: 2 x 1GB Micron 667MHz DDR2


HDD: Seagate 40GB PATA (jas 10.4.8 installed)

DVD: TDK 420N IDE (just something I had lying around)

PSU: Antec Earthwatts 380 (if it matters)


I chose the motherboard specifically because it seemed to be highly compatible based on posts I found on this board. The 40GB HDD has Tiger installed (jas 10.4.8) and it boots and runs fine (MBR partition scheme). The 500GB HDD is the device on which I want to install Leopard.


I've read a lot of posts on here about installing EFI, but they all seem to boil down to the following:

1) Partition your drive with a GUID partition scheme

2) Unmount the partitions on the drive to be installed to

3) Download and unpack the EFI files

4) ./startfiletool /dev/rdiskXsY boot_v8

5) dd if=guid/boot1h of=/dev/rdiskXsY bs=512 count=1

6) dd if=guid/boot0 of=/dev/diskX bs=400 count=1


Seems pretty simple, right? Well, I've typed these commands enough times that I have them memorized. Following is what I've done (booted from the Tiger install):


Verified the disk / partition identifiers:


$ diskutil list


#: type name size identifier

0: GUID_partition_scheme *465.8 GB disk0

1: EFI 200.0 MB disk0s1

2: Apple_HFS Leopard 100.6 GB disk0s2

3: Apple_HFS Home 264.5 GB disk0s3

4: Apple_HFS Repository 100.0 GB disk0s4


#: type name size identifier

0: FDisk_partition_scheme *37.3 GB disk1

1: Apple_HFS Tiger HD 37.3 GB disk1s1


Unmounted the partitions on the GUID drive I want to install to:


$ diskutil unmount /dev/disk0s2

Volume /dev/disk0s2 unmounted

$ diskutil unmount /dev/disk0s3

Volume /dev/disk0s3 unmounted

$ diskutil unmount /dev/disk0s4

Volume /dev/disk0s4 unmounted


As root, ran the following commands to install EFI:


# pwd


# ./startupfiletool /dev/rdisk0s2 boot_v8

HFS+ filesystem detected

Looking for 1 words free

reading 4096,4096

Marking word 812

writing back 4096,4096

allocated blocks 32 at start 25984

# dd if=guid/boot1h of=/dev/rdisk0s2 bs=512 count=1

1+0 records in

1+0 records out

512 bytes transferred in 0.010440 secs (49043 bytes/sec)

# dd if=guid/boot0 of=/dev/disk0 bs=400 count=1

1+0 records in

1+0 records out

400 bytes transferred in 0.018186 secs (21995 bytes/sec)


At this point, the partitions all mount as expected. When I reboot the computer, I just get a blinking cursor in the upper left corner of the screen.


Another thing: I know that the boot0 is being written to /dev/disk0 because I can read it back from the drive and it matches boot0 (it seems to be blank on a drive that has just been initialized as GUID). Also, if I write 512 bytes instead of 400, it blows away my partition table. ;) I haven't spent any time yet looking at the boot1h part of the process, but probably will soon.


So, I'm going to keep banging away on this, but if anyone can provide any assistance, I'd be most appreciative! If anyone who has this particular motherboard reads this, please let me know if there was anything that you had to do in BIOS to get it working. Also, if you could tell me what version of BIOS your board has, maybe I can dig up a similar level. The bios level of my board is NL94510J.86A.0025.2008.0107.1543. It's not the latest, and I intend to update it if I can verify that I can return to this level if I need to.

Link to comment
Share on other sites

  • 6 months later...

I am having a similar issue. I have the same Mobo. My system will not boot off my Internal IDE Sony DVD Burner. I get the same message "No Boot device found".


If I use an external USB DVD Drive the system will boot. I tried resetting my bios to factory but no luck.


If you can boot off of an IDE drive with your OS X install disk try hitting F8.... Type -s to boot into Single user mode and do a fdisk -e /dev/rdisk?? and flag you partition as bootable. This solved my boot problem off my IDE hard drive after my installation completed.


I also noticed that my IDE DVD drive is not reading all of my DVD disks. If I connect it via USB in an external case it works fine. Go figure.

Link to comment
Share on other sites


  • Create New...