Jump to content

IBM Thinkpad can't boot on battery,only on AC adapter,HELP pls


1 post in this topic

Recommended Posts

Hi :P !

I am new in MAC OS,

Before asking the help I read everything but did not found solution for my problems on IBM Thinkpad T40 (8255,ICH 5,AC 97,broadcom,ps2 keyb+touchpad+trackpoint,Pentium M):

1.I can't boot on battery, USB EHCI has been patched with PCGenUSBEHCI.kext,I 've

tried removed AppleUSBUHCI from plugin, the same effect just the USB keyboard and mouse did not work. The boot stops after initialisation of USBEHCI and root device detection,normal boot next mesage is related to USBUHCI.

35 8 0x2e60e000 0x27000 0x26000 com.apple.iokit.IOUSBFamily (2.6.1) <6 5 4 3>

36 0 0x2e935000 0x1a000 0x19000 com.apple.driver.AppleUSBUHCI (2.6.0) <35 16 5 4 3>

38 0 0x2e8ec000 0x12000 0x11000 com.orByte.driver.PCGenUSBEHCI (2.6.1) <35 16 5 4 3>

42 0 0x2f51b000 0x11000 0x10000 com.apple.driver.AppleUSBHub (2.6.0) <35 11>

51 0 0x2fac8000 0x4000 0x3000 com.apple.driver.AppleUSBComposite (2.6.1) <35 11>

67 0 0x28596000 0xf000 0xe000 com.apple.iokit.IOUSBUserClient (2.6.0) <35 11>

70 0 0x285db000 0x7000 0x6000 com.apple.iokit.IOUSBHIDDriver (2.6.0) <35 20 11>

2.I can't change resolution, the system preference limited to 1024x768 witch is native resolution of LCD.I tried to use "Graphics mode"=... , the resolution has been applied during boot process but when desktop appeared it take not all screen but only 1024x768, this mean on the rest of the screen I can see the boot log information.The desktop is not corrupted just the mouse cursor,so its a strange look. Calisto b3 used, open Gl nd Quartz Exterme are functioning

79 0 0x2da73000 0x34000 0x33000 com.apple.ATIRadeon (4.3.2) <72 71 16 11>

82 0 0x28686000 0x3000 0x2000 radeonTool (1.0.0d1) <16 5 4 3 2>

83 0 0x2e06f000 0x10000 0xf000 com.free.driver.Callisto (1.0.0d1) <71 16 11>


3.The immediately reboot after wake up from sleep. I am not sure if there is any solution for this.

4.The processor speed is always maximum,is any utility to adjust it available?

5.Keyboard layout not a required one (home,insert,delete and etc on the right extended part of keyboard 108keys are always digits)


The problems solved:

1.PS2Keyboard,Trackpoint and touch pad (by kextload in startup rc.local)

2. Broadcom 4320 wifi (card id added)

3. Airport (not detected by default Broadcom has been displayed as bult-in ethernet), rollback of the some kext to 10.4.10 was required

4.Can't connect or timeout in the refreshing the wifi network list,router channel changed from 1 to 11.

5. Built in ethernet, required to back some 10.4.10 kexts

6.PCMCIA II/III ,TI 1520 patch from XXX DVD 10.4.11 installed

7.AC 97 audio, AC97 universal audio installed, support 2ch,4ch,6ch

8.Battery indicator, patch from XXX DVD 10.4.11 installed

9.ATI Radeon 7500 patche installed, radeon tool, agpart 1.2, old opengl and callisto b3 QI:y, opengl:y, CI:n



I am runing version between 10.4.10 and 10.4.11, no problem except menioned above.

2GB ram,320GB hd, external monitor 1680x1080 20"


If you have a troubles with the problems

I've solved I'll happy to share how to install patches and where to find it.

sorry for my english,

hope on answer, even if it not a new laptop but i like my thinkpad and don't want to throw it.


From what I know it can't be used on Leopard system due to incompatible Open GL version between 10.4.X and 10.5.X and the fact that for ATI Radeon 7500 the Open GL kext for 10.5.X not exist and event that some hardware simulation for unsupported by hardware GL functions to be realised.



Leon, France

Link to comment
Share on other sites


  • Create New...