Jump to content

Install JaS 10.5.4 on Asus P5K SE/EPU


6 posts in this topic

Recommended Posts

I am starting this thread mostly to get help in getting Leopard fully working on my Asus P5K SE/EPU mainboard, but hopefully others can use this to get their system working. Or it can be a guide to hardware purchase.


Here is what I have:


Asus P5K SE/EPU -- $92

Intel Q6600 Core 2 Quad 2.4 Ghz -- $207

OCZ 2P1002PGK 2*1GB -- 57

OCZ 2P1002PGK 2*1GB -- 57

LG GH22NS10 20x DVD-R/R DL SATA -- 29

eVGA Nvidia 7900GS 256MB -- n/a

MS IntelliPoint USB mouse -- n/a

MS Ergo 4000 keyboard -- n/a

Maxtor 300GB SATA2 -- n/a


I am using JaS 10.5.4 installer.


First hurdle cleared -- Still Waiting for Root Device

-- Starting the install process


At first I was unable to start the installer because I only had an IDE DVD drive. For some reason the IDE controller is not recognized by either Leo4All or JaS. To get past this I performed the install using a IDE-USB enclosure, where I attached the CDROM to the external enclosure. This worked in getting the install done.


I got tired of this and bought the LG DVD drive mentioned in the original post. This sped up the install slightly, but not worth the $29 I spent on the DVD drive, and the fact I had to give up a SATA port to do that.


Second hurdle cleared -- Install Failed

-- Unable to finish the install.


I looked at the log and changed the filter to show all messages. It seemed that because I had a space in the name of my hard drive many of the scripts were failing to run.


So I changed the name of the hard drive from "Macintosh HD" to "Leopard".


Third hurdle cleared -- Looping at Migration Screen

--Looping between Welcome Video and User Migration screens.


I posted about this already and Hawk Pedgion answered it. To get past the User Migration screen, you need a FireWire port. So I added my SoundBlaster Audigy card, and it found the FireWire port on it and I was able to get past that.


Outstanding issues--What still doesn't work


The following things aren't working:

No LAN -- Can anyone suggest what I should choose to get LAN working on this Mainboard?

No Audio -- I have some hints about using a particular ACL883 driver. Will update trying it.

No Wake from Sleep-- I can put the system to sleep but it doesn't come up. This is what is bothering me the most. I know people have had success waking their system using the same mainboard, but I don't know what I need to do to get this to work. Any help would be Greatly appreciated!

Link to comment
Share on other sites

I have been able to resolve the following issues:


LAN -- I installed a Marvel Yukon 2 LAN card and used skge driver. Worked fine. I have not yet been able to get the on-board LAN card to work though.

Audio -- I used the link http://www.mediafire.com/?j0lnmnwwgms to download ALC88e-eLineOuts.zip. Now I have line-out and mic-in working. Nothing else though.

IDE -- I missed stating that my IDE was not working. It is now, thanks to a modified AppleVIAATA.kext. I found that at:



So the only thing outstanding is my Resume/Wake from Sleep.

-- Any help here?


I'm still missing the on-board LAN but I'm making do with the PCI card.

Link to comment
Share on other sites

Wake -- Well it looks like Wake now works. I'm not able to resume via USB but I can press the power button and that wakes the system. I'm not 100% sure if this is going to break-down after some time like on Windows. So this is a maybe.


That said, the only outstanding issue is the on-board LAN. But looking at the HCL wiki it seems that the on-board LAN doesn't connect properly after Waking from Sleep mode. So maybe it's better this way.


So it seems like I'm close to 100% with OSx86!

Link to comment
Share on other sites

  • 2 weeks later...

Another update.


I have FireWire working by using the Leo4All kext. I got some lock-ups after using them, but couldn't isolate those kexts as the problem.


I also got LAN working. I installed the atheros L1 kext. It is better than the Yukon2 kext because those had some performance issues and I also had trouble uploading files. Of course I don't know if these kexts are stable, and if stable whether they support wake and sleep.

Link to comment
Share on other sites


  • Create New...