Jump to content

Leopard 10.5.4 on a Dell 1520


2 posts in this topic

Recommended Posts

I recently installed iATKOS 10.5.4 on my Dell 1520. However, once I tried to boot it up, it gave me an error saying "Cannot find Mach_Kernel". It also wrecked my Vista installation, giving me there error that winboot.exe was corrupt or missing (startup repair did not fix this). So, here's everything that I did, including my setup.


My Setup:


Dell 1520

*Windows Vista Premium

*Intel Core 2 Duo 2.0 gigahertz

*Nvidia 8400m GS 128mb memory

*2gb DDR2 memory

*Intel Wireless pro

*Sigmatel HD Audio

*160gb sata hard drive



I began fresh. I put in my Vista DVD, created 2 partitions, 55gb for Vista, and the 95gb left was unallocated space. I then opened up DISKPART, did all the steps to create a proper format for mac (used this guide: http://forum.insanelymac.com/index.php?showtopic=39253), and then downloaded iATKOS 10.5.4. I restarted the computer, got to the mac screen, went into DISK Utility, erased the partition, and then selected the partition to install mac on.


It was at this point I clicked customize. Using this guide ( http://www.insanelymac.com/lofiversion/index.php/t90398.html ), it told me to only check off:




- Stock Kernel


- Stock Apple ACPI Platform


- Broadcom 440X


Having done so, I installed mac. Once that was installed, I again went into Disk Utility from the iATKOS DVD and ran repair permissions. Everything installed smoothly, however, when the computer restarted and I tried to run the parition in Darwin that held Mac OSX, it gave me the error listed above; "Cannot find Mach_Kernel". It would not go beyond this. I haven't found an answer to that problem after searching these forums, so perhaps I did something wrong while installing?


Right now I'm all set to go again with the 95gb of unallocated space, and Vista is installed. Thanks in advance for the help!


By the way, I recently read a guide suggesting I type this in the Darwin Boot Loader:



-1 (disk number)

-3 (partition number if your Leopard is installed here)




Apparently you have to do that, restart, and then boot up Leopard? I think I'll wait for replies before trying this, as I realllly don't want to have to reformat Vista again if something goes wrong.



Link to comment
Share on other sites


  • Create New...