Jump to content

Request Guidance on iATKOS v4i


2 posts in this topic

Recommended Posts

I am an utter n00b at this, but I thought I would give it a try.


I am attempting to install iATKOS v4i on a Thinkpad Z61t. It's a Core2Duo machine with a SATA hard drive and Intel graphics -- sufficiently similar to MacBooks that I'm of the belief most of it should work right away. There is an existing installation of Debian Linux, Windows is nowhere to be seen, the disk partitioning scheme is MBR, wherein GRUB-2 is installed and starts the show. I've actually gotten as far as booting the iATKOS DVD and installing OSX on to the hard disk. What's not working is getting it to boot.


OSX is installed to /dev/sda7 (disk0s7). This is an extended MBR partition, and is not marked bootable. Using the GRUB-2 command line, I have attempted to boot OSX using the following commands:


chainloader --force (hd0,7)+1

Once done, I see the message "Loading kernel" flash on the screen, then black, with no further activity. The machine must be power-cycled to reboot.


I installed the "default" kernel, which is to say, the kernel iATKOS pre-selected for me. I also selected the SATA driver, the Intel 955 graphics driver, and the Intel SpeedStep support kext (since the README expressly said that would work on a Core2Duo).


My completely wild guess is that the EFI shell/shim/component-thing isn't getting loaded correctly. Using Linux, I've done some quick poking around on the OSX partition, but haven't found any obviously-named files that suggest themselves to be the EFI widget.


So, some quick questions:

* Did the iATKOS install leave something out?

* If not, where's the boot image GRUB should chainload?

* Does OSX need to be on a primary partition and not an extended partition?

* Does the partition need to be flagged as bootable?

* Is it probably something else I fouled up?


Thanks in advance for any and all suggestions.

Link to comment
Share on other sites

Well, I got a bit further today. I partitioned the disk again, this time giving OSX a primary partition, and marking it bootable. After running the install process again, I was greeted with the Darwin bootloader. From there, I booted to the Welcome movie, configured OSX, and was greeted with the Mac desktop.


Sound support worked immediately, but the same could not be said of the network interfaces. Sadly, the whole thing was rather unstable. If I left it alone, it would idle along just fine. But the moment I tried to launch or quit applications, there was a non-zero chance of triggering a kernel panic.


The biggest problem, however, was that the installer put the Darwin bootloader into the MBR and blew away the existing GRUB, rendering my Linux install inaccessible. One bootable GRUB CD later, I managed to get Linux bootable again, but that of course blew away the Darwin bootloader (since OSX was so unstable, I didn't mind so much).


So my big question now is: How does the Darwin/EFI bootloader actually get loaded? Does it load the first N blocks off the OSX paritition? Load a file (which file)? How can I boot into OSX again without having to blast GRUB to smithereens?


Once I can get booting into OSX without hassle, then I'll worry about improving stability.


Once again, my thanks in advance for any help.

Link to comment
Share on other sites


  • Create New...