Jump to content

bad kexts and nothing I do helps


5 posts in this topic

Recommended Posts

I have a P5W DH Deluxe with Asus EN 7300GT... I HAD everything working on 10.5.4 except QE so I was trying to find some kexts that would help the situation.. Well needless to say the ones I tried didn't help at all. I can only boot to single user but I am not very advanced when it comes to Bash and I don't know how to take them out and replace them with my backups that are on another drive in my Computer. Any help with the bash commands I would need to use to get up and running again would be greatly appreciated..


ohh i used kalyway 10.5.1 then upgraded from there.



Link to comment
Share on other sites

To remove files

rm -rf file.kext

Be warned that this command is unforgiving. If you mistype then you could loose your info.


To move files

mv -f file1 file2


To copy files

cp -R file1 file2


To change Directories

cd directory


To list the files and directories of the folder your currently in



EDIT: Forgot about the permissions


To repair file permissions

chmod -R 755 file.kext


chown -R root:wheel file.kext


Then you have to reload your kexts. You can either boot with the -f flag or you can delete /system/library/extensions.kextcache.

Link to comment
Share on other sites

I can help you some of the way. I messed up a fair few times with replacing kexts and with quiet boot/no timeout set I had to boot into the leopard install disk and run terminal from there to fix things.


To change to the directory containing the bad kext:


cd /System/Library/Extensions


To view the contents:




To delete a rogue kext:


rm -rf itsallmyfault.kext


You should also delete the extensions.mkext in /System/Library too.


To restore the good kext:


cp -r "/Volumes/Other Drive Label/Backup/original.kext" /System/Library/Extensions


I don't know how to repair permissions yet though.

Link to comment
Share on other sites

If it's in your storage directory then it's already mounted. Else, if you want to mount something

sudo mount -t file_system_type /dev/device /path_to_mount_point


sudo mount -t ntfs /dev/sda1 /Volumes/Windows

Link to comment
Share on other sites


  • Create New...