Jump to content

Issues with MACPAR (kernel panic)


3 posts in this topic

Recommended Posts

Alright, first thing is first.


Kalyway 10.5.2

Sleep kernel


Asus P5N-T Deluxe http://www.overclock3d.net/reviews.php?/cp...i_motherboard/1

8800 gtx

4gb ram - (maxmem set to 3300)

HDD - Nforce sATA

Intel q6600 cpu

some realtek pci NIC that showed natively in OSX, not sure of the model number, but it is a few years old and even has lights for 10 and 100mb modes. :D



Okay, I have everything working as far as I can tell, but one problem remains. Whenever I try to extract a large file with MACPAR I get kernel panic at varying points during the extract. I read some solutions here http://forum.insanelymac.com/index.php?showtopic=103753. I tried the maxmem change, however, I am still having some issues.


According to this post:

"it seems there is a better fix for this problem. Apparently there is a bug related to IDE device handling somewhere, perhaps in OSX. If all of your devices are SATA, then make sure to put your mobo in AHCI mode for your SATA devices instead of IDE mode. Apparently this gets rid of the need to limit maxmem. I am testing right now with full 4GBram and so far no kernel panic. I didn't have to do anything fancy to get OSX to work in AHCI mode with 10.5.2, it just worked. However, if I ever decide to dual boot into XP then I will have to load the AHCI drivers manually for xp to boot up. A bit of a pain, but XP...what is that?"


There is supposed to be a AHCI mode toggle in my bios, but I don't see it anywhere. It may be that the setting is unavailable for me. Would I have better luck putting the OSX system drive into the Marvell 88SE6111 slot, even though it is external. :wacko:


Does anyone perhaps have a solution for me, that I might try. I appreciate the help. Let me know if you need anymore informaiton from me.


VMware fusion also gives me Kernel Panic during installation of XP.

Link to comment
Share on other sites

Okay, after a few tries I finally got VMware fusion installed so I can use my Zune software and what not. I am still having an issue with macpar however and any help would be appreciated.



Looks like setting my memmax to 2048 may have gotten rid of the issue. It seems to be related to the modified applenforceata.kext I installed. Do I have to use that .kext for my system?


Alright, everything seems to be working great now other than having only 2gb of ram available. I even played some age of empires 3 and it ran without a hitch.


Hopefully this helps someone else with similar issues in the future.

Link to comment
Share on other sites


  • Create New...