Jump to content

usb 2.0 issue 10.4.8

1 post in this topic

Recommended Posts

hey guys. sorry to bother you with this little problem. i just can't seem to solve this one. this is probably the last one that i really need to get over with because it seriously messes up with a lot of stuff. backup, dvd burning (i use an external drive), even with my iPod, so i really hope i can get help from you guys.



well, basically the problem is that i just my usb won't go faster than 12 Mb/s. but i know for a fact that these are 2.0 ports, as they worked that way when i was running windows.


anyway, as i've noted in the topic, i installed jas 10.4.8 on my system, but i used that upgrade which makes it seem like im running 10.4.11/darwin 8.9.1. i just hope this didn't mess with everything because that would suck a lot.


so i've already stumbled upon orByte's usb fix, and tried first the fix for the 10.4.8/8.8.1 version, but sadly after installation/rebooting, the usb device wouldn't even be recognized. so i went on and installed the 10.4.9/8.9.1 version of IOUSBFamily.kext. gladly, the usb was recognized again, but not yet as a 2.0 device.


so, i then applied the PCGenUSBEHCI 2.7.0 fix (and i followed every direction), and upon restarting, still i wasn't read as 2.0



heres what system profiler says:


USB Bus:


Host Controller Location: Expansion Slot

Host Controller Driver: AppleUSBUHCI

PCI Device ID: 0x2658

PCI Revision ID: 0x0004

PCI Vendor ID: 0x8086

Bus Number: 0x1d



and then heres what comes from (sudo dmesg | grep EHCI) or (sudo dmesg | grep USBF) they both come up the same:


USBF: 27.970 AppleUSBEHCI[0x2dde000]::UIMInitialize - unable to get device memory

USBF: 27.970 AppleUSBEHCI[0x2dde000]::UIMInitialize - Error occurred (0xe00002be)

USBF: 27.982 AppleUSBEHCI: unable to initialize UIM



upon searching in the forums, i found out a user who encountered the same problem, but fixed it upon disabling Legacy USB support. i tried the same thing, but that too wouldn't work out for me.


now, im completely lost.


any help guys?


thanks a bunch to you all! :unsure:






Acer Aspire 5500z


768 MB RAM

intel gma915 (QE/CI working, still with 2-pin fix)

intel 2200bg wlan (working)

broadcom ethernet (working)

conexant modem (haven't bothered trying)

audio (works)

Link to comment
Share on other sites


  • Create New...