Jump to content

Problem with update to 10.5.3 Kalyway


10 posts in this topic

Recommended Posts

Hello guys.


I`m with kalyway 10.5.1 dvd, and I updated it with comboupdate kalyway to 10.5.2. Now I`m with the comupdate to 10.5.3 buit I`m having some problems!

When I install it ok, when it asks for restart I just ignore it and install the kernel, it asks which kernel I want to install, I selected vanila kernel 9.3 and installed it. Then I restarted the computer.

In this restart I did F8 and typed update -v, but when it restarts again after this procedure it stops in a blue windows. I tried restarting again, pressing F8 and writing -v -x, I tried writing update -v without entering in F8 before.

But all the times it stops in the blue window.



My notebook is an:

Acer Aspire 3690-2023

Celeron M 430 1.73Ghz


120GB HD


Somebody can help me with this comboupdate to update my kalyway 10.5.2 to 10.5.3??\



Link to comment
Share on other sites

It`s Intel 945GM


Yep I had the same issue.


Ok so BEFORE you install the update and the kernel, go to /System/Library/Extensions and find these 2 files: AppleIntelIntegratedFramebuffer.kext and IONDRVSupport.kext


Back them up somewhere (preferred Desktop) then run the update/kernel install and DO NOT REBOOT. Now copy the 2 files you just backed up back into the folder they came out of, replace the current files in there, Authenticate it, Repair permissions, then reboot. If it still doesn't login right then type update -v and that should fix it.

Link to comment
Share on other sites

Thanks. I`ll have to do everything again because I`m in that blue window. I`m starting now. Thanks for your help. Anything wrong can I ask you again if you know how can I do? Thanks.

Link to comment
Share on other sites

Sure you can ask. Also I just found this out recently, if you install OS X form the new iATKOS DVD, I no longer have any mouse artifacts with the Intel 950 GMA. I used to alway have them when I installed from Kalyway's DVD.

Link to comment
Share on other sites


Here I am again.


I just made the backup (copy, then paste in the desktop) of AppleIntelIntegratedFramebuffer.kext and IONDRVSupport.kext. Then I installed update and kernel, but now when I try to take the both kexts and replace them again it says I dont have permission.


I know you said for me to repair permissions, but I don`t know how.


If I replace them one by one, AppleIntelIntegratedFramebuffer.kext is asked for my permission and password to be replaced, but IONDRVSupport.kext isn`t, the system just say I don`t have permission to replace it.


Can anyone help me with this?



-------------------1st edit---------------------


I learned how to set the permissions and I just made it, now I restarted the computer, but it is stopping in the Apple loading windows now.

It stays loading forever.

I will try update -v.

------------------2nd edit---------------

The update -v didnt solved the problem.

It continues to stop in the apple loading window.

Can I try anything else??

Link to comment
Share on other sites

Thanks espionage.

Im already downloading the iatkos v4i.

But now, without it I`m trying another way I found to install this update, but without the kernel 9.3. I dont know if it will change a lot(if it works, sure).


Thanks for all your help.

Your help solved the problem I think, because the window that it was locking changed. But I think I have other problems too. Hehehe

Link to comment
Share on other sites


  • Create New...