Jump to content

[Toshiba Qosmio] The Q Source


1 post in this topic

Recommended Posts

Although there are many models of Qosmio, most seem to be similar enough in nature that they share common issues and solutions. As I resolve the issues, I am going to post the solutions here - and encourage the other Qosmio users with experience to join in.


[Zillion & James - This means you :D ]


I'm starting with Kalyway 10.5.2 and moving up, so assume all answers work on Leopard.

Have since installed JaS 10.5.4 without issue.


This is my Qosmio: Everest Hardware Report


It's a "Mobile DualCore Intel Core Duo T2600, 2166 MHz" and it goes pretty well:

Everest Benchmark

XBench Results


It weighs in at a little under 7.88kg, so if I may coin a phrase ... "Luggintosh?"


LAN: Mine worked out of the box.

Intel® PRO/1000 PL Standard Broadcom 57xx drivers. After owning a Dell, this was a bonus.


WIRELESS: Intel 3945ABG :) Great cards, but there is no working OSX driver. Buy a Dell/Broadcom replacement card, they work OOB. I have a PCMCIA Ubiquiti [untested] and my laptop weight about 19 kilograms, so wireless isn't a big thing.


DUAL CORE: I don't have Dual Core 2, just regular old-fashion Dual Core - and it works fine.


BIOS: I don't use any particular special settings, all the good things are enabled, no different to what I would normally use with XP. I'm pretty sure it can sleep okay, but then I've seen it hang for no known reason after lasting the entire night without use. I use "OS Selected" devices, at the moment it's set to run at maximum power (assumedly that equates to SpeedStep = OFF), but I have had it running with all the fancy features enabled without issue.


[update: Sleep doesn't work so well]


USB/PCMCIA/PC Express: All seems to work fine. All the 4 USB ports are funcitonal, and my PC Express slot works with my Novatel Merlin XU870 (Driver: XU870-OSX-V1.7.2.zip). It appears as a WWAN device in Networking and integrates well. No SMS tool that I can find though yet.


To get PCMCIA Card Bus to work, get Beta 3 (or later) from this thread: http://forum.insanelymac.com/index.php?sho...1036&st=600

or grab it from my site - http://osx.ipspace.com/?dir=programs (It's called PCCard10.5.2Beta3).


BLUETOOTH/SERIAL/FIREWIRE: Assumedly it works - actually there is no serial port - evidently no room after the Antenna, Composite and HDMI inputs.


CARD READER: One of those SD CARD affairs, my only SD card is broken, so I'm not sure if it works (not sure I care either).


VIDEO: I have a GeForce 7600 Go 256MB, 8384:0398. You have two choices, fully accelerated Quartz/CI on an External monitor, or VESA 1280x1024 on the internal monitor. This seems to apply to all the other Qosmio/GeForce combo's too.


The easiest way I found to get this working, was NVkush. Just double click it, and you're done. Fully accelerated external video output - pretty white/blue starbusts on your internal LCD. If you wanted a laptop you shouldn't have bought a Qosmio anyway. :D


It also uses NVDResman, NVDA40Hal, and GeForce kext's. They came with Kalyway, although I have tried countless variants in an effort to get the internal display to work.


I don't believe [but haven't looked hard] to see if anybody has developed a way to get better VESA resolution for those who want to run the inbuild LCD (non-accelerated of course) at full 1920x1200 resolution. I actually run it at 1280x800 in Windows because I value my eyes.


Potentially (in the future - maybe now) there may be a VESA trick to accomplish custom resolution. I've seen it in Linux, used to run a GMA945 at it's native resolution. (See BackTrack Bootle Linux). it altered in memory the VESA specs to allow user-specified resolutions. Something may be developed for OSX, or may already exist. I may look at it one day - starting with NVinject's 512 BIOS patches.


I run the Bios in "LCD + Analog" monitor mode, it seems to allow me to keep the lid on my Qosmio closed and reboot, use an external keyboard and monitor, and with the power saving in OSX set not to turn off when the lid is closed, means I rarely have to touch the actual laptop.


SOUND: Nearly gave up, but works now. However if you dual-boot into Windows, you have to go into BIOS and save settings (no need to change anything). So <ESC><F1><END> Y <ENTER> (get used to it).


These days it seems that once I boot Windows, I cannot get Audio back without "upgrading" BIOS. Very scarey.

Since my sound is currently working, I'm going to dump all the files and info for my own reference, so I have a "Known Good" configuration to return to later if I need it.


ioreg output

kextstat output

lspci output [insert plug for Osx86Tools]

[Other great tools: Kext Helper, PListEdit Pro].


I used my own codec dump [insert plug for Backtrack 3 ISO/USB bootable Linux] with a copy of

AppleHDAPatcher v1.20. It seemed to work better than other copies of the same, so I'm uploading it, along with the files it came with for superstition's sake. I believe I'm using ALCinject (installed automatically by AppleHDAPatcher), not the HDAEnabler.kext that is in the archive, although they probably both work - I just don't care that much.


Here is ALCinject in my dmesg:


ALCinject: Starting.

ALCinject: Setting built-in=<data not shown>

ALCinject: Setting layout-id=<data not shown>


AppleHDAPatcher installed it automatically, and it works. Haven't tested inputs, but speakers and outputs work.


If you just want to look/copy my working kexts, here's a snapshot of what's in use at the moment:my kexts


Only ALCinject, and AppleHDA kexts are used AFAIK.


I'm running [what I believe to be - not 100% sure how to check] 10.5.3 Vanilla Kernel from Kalyway 10.5.3 Combo Update, and I assume EFIV8 on an MBR partition. Basically whatever Kalyway did.


GADGETS: Biometrics, Digital TV tuner, HD-DVD, HDMI output, Composite output & input...


Apparently the Biometric Scanner will work if you download the Protector Suite from http://www.upek.com/solutions/mac/default.asp ... haven't really tested it.


N.F.I. :wacko:


Biometrics appear as USB device so I assume they work with the appropriate software. Don't really care. I didn't buy it for all that stuff. I bought it because it was on sale. What can I say. It was cheaper than a MacBook, heavier than a G5 tower, and faster than both. Twin hard drives make it extra-easy to dual boot (although I'm using half drive, MBR, with Acronis for O/S switching.)


Oh - and the giant shiny volume dial works too - you might need ApplePCINub or whatnot.


SUMMARY: The perfect Luggintosh - if the internal screen could be persuaded to work to it's full potential.


If any links are broken (I typed them mostly by hand) just browse manually from http://osx.ipspace.com/ and you should find what you need.


Check thread on Toshiba A100 for possible ideas too - http://forum.insanelymac.com/index.php?showtopic=113047


Link to comment
Share on other sites


  • Create New...