Jump to content

Vostro 400

8 posts in this topic

Recommended Posts

Dell Vostro 400 Min-Tower

CPU Intel Core 2 Quad (currently kabyl 9.2.2 kernel I think)

MB Foxconn XXXXX - yes working, except below

RAM 2GB 800mhz - yes working, generally in system profiler, error on more info?!

Video card PNY Nvidia 8600 512mb (upgraded from 8300) - yes working (haven't cecked QE yet)

Realtek ALC888 on Foxconn - not working

Intel Ethernet on Foxconn - not working

SATA on Foxconn - yes working

Apple Ethernet 10/100 PCI - yes working

Some $7 Firewire/USB PCI - yes working

Restart - yes working

Shutdown - causes reboot

Sleep - not working, goes to sleep, need to powerdown

Kalway 10.5.2

10.5.4 software update combo breaks entire install

Download 10.5.3 Kalaway combo, but haven't installed yet


Okay this has taken days to get this far... Resolved ethernet by installing Apple card. Patching the intel ethernet kext plist failed. Installing ALC888Audio.mpkg and ran AppleHDAPatcher v1.12.app with multiple versions of alc888.txt failed to get the motherboard audio working. Now out of PCI slots, so I'm going to go buy a USB or firewire breakout box for audio I/O. Haven't swapped kernels to fix sleep/shutdown issue, but don't expect it to work.


All in all I regret getting the vostro w/o checking the motherboard specs first. May sell and get another Hackintosh. Not a recomended motherboard until someone writes drivers. Recognized as a Mac Pro for half the price however.


Any ideas on getting stuff working?

Link to comment
Share on other sites

Okay I got an Alesis io|2. I was thinking about getting an external audio box anyway for recording.

I haven't even installed the drivers yet, but I got audio out. No music for a week, now I am I heaven.

Link to comment
Share on other sites

Okay I've been troubleshooting the sleep problem.

Not sure if it's a motherboard issue or video card issue.

If I put it to sleep with apple menu, key/mouse has no effect.

After sleep the PC powerlight blinks, and pressing the PC power button

seems to wake up the computer, but video doesn't come back.

I checked pmset, and it indicated hibernation was 0,

which I believe means standby yes, hibernation no,

which is what I want.


So I though the next thing was to start swapping kernels,

I went to the bootloader plist and changed the indicated kernel

to kabyl-kernel from mach-kernel1. Now the OS X won't boot at all,

even to safe mode. I've tried switching the kernel at the bootloader instead

to no avail. So I'll either need to fix it at single user, make second mac partition,

get mac os extended viewable in XP or reinstall, blahhh, tanked!


No matter how I boot -v it hangs at "Property 'Driver-1d1c000".

Any ideas ow to get it back? Was my method incorrect?


Is anyone going to reply to me? Or am I beating the dead horse of my own personal record?

Link to comment
Share on other sites

Progress, after not much...


I have sleep! I switched the Bios from from S3 to S1.

I guess that means it's less efficient sleep.


I have tried most of the kernels and haven't gotten S3 sleep to work.

Although, in the meantime, I learned all about the bootloader and and it's prefs.

Vanilla with platform=osx86 is fastest to boot.

Still can get get the syntax down for default, still trying to -v without breaking booting, wtf.

Need to try other nvidia drivers now.


Mostly I want to leave it on and not get to hot,

Like the day I left it on without sleep.

When I got back it was like and oven, I exaggerated in the cabinet.

And it's sound real loud.

Well it turns out the computer was fine, but the noise was the video fan.

I removed the sticker card that was riding away and all was well!

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

As far as I know on board ethernet does not work.

I'd find a OS X supported PCI card if I where you.


I have no idea about drivers I just installed what came with the install.

Every time I install drivers I break things.

Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

  • Create New...