Jump to content

OS X 10.4.9 up and running on HP Pavilion a1200y


2 posts in this topic

Recommended Posts

Well, I recently aquired an HP Pavilion a1200y desktop (2.93 ghz Celeron D), which after some research discovered should run OSX. I tried four different versions of patched DVDs and found an iAtkos 10.4.9 version to be the only one that worked for me (perhaps bad copies/burning, or just bad configuration on my part) Either way, I got it up and running.


I did a bit of upgrading from the stock unit, such as upping the RAM to 2 GB, a Pioneer SATA DVD burner, and a 160GB SATA hard drive. I also have installed a Dynex PCI Wireless card.


Here are the install options I selected (through trial and error) to get it working...

*Remove CPU Powermanagement.kext

*Verbose Mode (helps determine where things might be going wrong)

*VIA SATA/ATA drivers (would hang up 'waiting for root device')

*Azalia Audio (would not play sound without this)

*MenuMeters (kinda cool to check CPU/Memory usage)

*I placed the Chain0 file in the root of C: (this computer has XP Pro installed)


Some issues I am still having are...

*Computer will not go into sleep mode (Not a big issue, since the computer boots up SOOO fast...About 30 seconds, I can just shut down and reboot later)


*I have found the OWC Wireless Setup v3 3t install (in an attempt to be able to use the Dynex Wireless card), will not completely install. (Hangs up about 1/4 through the first step)


Any suggestions on these two issues? I Love Macs, I have a 233mhz Wallstreet and a 500mhz Pismo, but this PC runs so fast, the only thing missing is an internet connection. I have tried installing the OWC....mpkg through Terminal with the iAtkos DVD, but cannot find a way to open the package through Terminal.


...AND...Thanks to all the posters and responders from previous entries...I referred to this site MANY times while attempting to do my install, and found so much useful information. :D

Link to comment
Share on other sites

  • 1 year later...

Hi. I was hoping you could provide a little help as I have a somewhat similar setup (a1200y, Pentium D, two SATA HD, one IDE DVD-ROM, one IDE DVD-burner). I am getting intermittent luck in booting up IPC 10.5.6 on DVD. I get the error message "waiting for root device" 90% of the time. Once in a while the DVD will load. Once the DVD loaded, I was able to do an install to one of the partitions in a SATA HD but I didn't get too far when booting from the HD (black screen).


I'm trying to solve the "waiting for root device" problem first before figuring out the HD install issues. The fact that it boots once every twenty tries makes this hard to diagnose.


I tried a few ways of booting up the DVD (unplugging all HD, unplugging each DVD) and a bunch of different boot flags as well (-x, platform =x86pc, etc.). In looking at your setup, my conclusion is that the IDE DVD drive is the issue. Do you think using a SATA DVD drive (and unplugging the IDE DVD drives) will solve the "waiting for root device" issue? Any other advice?


Thanks in advance.

Link to comment
Share on other sites


  • Create New...