Jump to content

[SOLVED] DV Cam not detected by FCP, iMovie 7.1 or iMovie HD..


2 posts in this topic

Recommended Posts

SOLVED: See below, may be useful depending on how many others have this issue.



UPDATE: On boot, a line appears which notes a link/load error on IOFirewireAVC.kext.



Hi All,



I've been scouring the web trying to find a fix for this problem. I've attached a Canon MD101 MiniDV cam via Firewire... running Kalyway Leopard 10.5.2 updated (without a hitch, it seems!) to JaS 10.5.3).


It is showing in System Profiler, here's the output:


FireWire Bus:


Maximum Speed: Up to 400 Mb/sec




Manufacturer: Canon

Model: 0x0

GUID: 0x85000173DB0A

Maximum Speed: Up to 100 Mb/sec

Connection Speed: Up to 100 Mb/sec


MD101 Unit:

Unit Software Version: 0x10001

Unit Spec ID: 0xA02D



But iMovie refuses to acknowledge that there is a camera attached. I've replaced the firewire kext to get rid of the security mode error, which seems to have worked as the error message no longer appears when I boot in verbose mode, but still no luck.



Any ideas?

Link to comment
Share on other sites

Just in case anyone else is having this problem:



Turned out to be a firewire issue. If anyone is having problems with ANY device not being accepted by software, albeit being recognised, try solving the Security Level error by replacing IOFirewireFamily.kext with the 10.4.8/10.4.9 version - and then ALSO replacing IOFireWireAVC.kext with the 10.4.8/10.4.9 version.



iMovie HD now captures audio flawlessly. iMovie 08 seems to have a strange lag, which I can only assume is a software flaw, as HD & FCP seem to work fine.

Link to comment
Share on other sites


  • Create New...