Jump to content

External USB Drive

2 posts in this topic

Recommended Posts

I was trying to install to an external USB drive. I realize it's a tad optimistic, but I might as well try, as I don't have any internal harddrives left (laptop).


Anyway, I got further than I thought, after doing something like

dd if=tiger-x86.img of=/dev/sda ...

I actually had a bootable usb harddrive (without a partition table I guess, but what the heck...). Anyway, the apple logo came up and then a box telling me to reboot my computer. I tried the -x -v mode and I got as far as a message telling me "AFH Not Supported" whatever that means. And then after a while it said something like "Waiting for root filesystem" (maybe not that exact wording, I will have my digital camera ready later:) ).


So, to my question: Have anyone accomplished a bootable OSX(86) installation on an external hard drive? Can it at all be done? (I know windows xp refuses to do this but linux will if usb is in the kernel and not in modules). Anyone?


EDIT: I also had to enable "USB Emulation" in the BIOS, and bring up the manual boot menu and select "External USB device".

Link to comment
Share on other sites

Not that I would use this kind of software as it borders on what might some say "illegal" but(hehehe) If i did try this stuff out i would like to say this:


I would have tried it only on desktop machines as i would have access to some HP desktops that have intel 915 chipsets and i was able to boot to an external USB machine. The problem that i encountered was that it would always get stuck at "jetisoning File system" when ever i would just use it as external Drive. I was finnally able to reliable get it booted by removing the Hard drive from the USB external enclosure and ataching it to the Desktops IDE controller. It would boot perfectly. Afterwards i would shut it down and put it back into the USB controler and then it would boot!

This only works for the machine it was atached to "IDE" internally. My guess as to why this works is: When you boot it IDE it doesn't have to load drivers for my USB caddy(external enclosure) which is something like IOUSBMASSSTORAGE.KEXT. Because i would get a kernel dependency error and it wouldn't get muc further or get stuck at that point. BUt when i load it on IDE it would actually boot properly and make a "driver/kext Cache" and when booting from USB it wouldn't need to "detect" all that stuff. I assume this because I have multiple machines/configurations that i have access to and When you "Move" the usb to another machine with different chipset(INtel 865 chipset for example) it would stop booting from usb untill you put it in IDE and boot then shut down and put it back into caddy afterwards it boots to USB happily. I am going to make a post when i get my data together about how i got the USB to boot on the desktops i have access to.

Link to comment
Share on other sites


  • Create New...