Jump to content

Inspiron 1520 gma945 video black screen


6 posts in this topic

Recommended Posts

OK, this is my first attempt at installing OSX on a PC. So far, I've installed it about 20 different ways with no fix for the video problem. Here's what I know:


Using IATKOS 2.0i Re-Release


System: Dell Inspiron 1520

CPU T7100 1.8


Intel GME 945 video chipset

15.4 display limited to 1280x800


I've installed the system in every possible combination so far - with and without: Hyperthreading, single core, all onboard devices off, every option in the installer on, installer base, installer base with one item checked each time, etc.


Only if the system has been installed with just the base items checked can I get to the GUI - and even then I have to -x -v to get to it. Once I -x -v my way into the GUI, that's it - if I reboot I cannot get back into it no matter what switches I throw at it. Otherwise the system boots just fine, flips to the blue screen for half a second and then the display turns off.


If I hook up a second monitor to the laptop, I can drag the mouse over to it and see it just fine. Something is turning off the laptop screen - resolution out of range?


I've tried setting the resolution to 1280x800 and 1024x768 at the boot prompt with no luck. They seem to have absolutely no effect on it.


I've tried putting the laptop to sleep, but without seeing the display I can't tell if its doing it or not. The hard drive light flashes for a second when you press the power button, but the fans and other normal activity are still there.


I've been searching the major forums for the past three days and haven't found a solution that works. Can anyone give me some insight on what I need to do? If the answer is already out there I must not be searching for the right terms.


Also, if there's no way for me to get to the GUI as it sits, how do I edit the required files to fix the situation? Kind of a catch-22 spot I'm in.


I'm at a loss.


I've attached a shot of System Profiler displaying my video card info during one of the times I was able to get in it. Oddly enough, it uses the same ID codes as the Intel 3100 does...


Link to comment
Share on other sites

Just to update, I was finally able to get it to boot to the GUI consistently by removing all files related to gma950 and the AppleIntelFramebuffer


Still stuck in vesa mode though.


hi, read my other recent posts. I have gma950 (see sig). When I recently installed 10.5.3 I got a black screen also. After setting a hot screen corner to wake/sleep after mouse over I was able to get my desktop by moving mouse to that corner (in my case upper right), leave it there move it back to main desktop (of course you have to use your imagination here, since it's black). That triggered wake/sleep and got my desktop back. Maybe this will work for you ... maybe not. worth a try.

Link to comment
Share on other sites

Hi, what u hv to do is the try to remove the AppleIntelFramebuffer.kext and replace it with the old 1 from the 10.5.1. do not delete any more kext. these kext are needed for ur system to boot..........

U get a black screen because of the apple graphics update which comes with the 10.5.3 update. just delete theAppleIntelFramebuffer.kext and copy an old version from 10.5.1 .....n u should be fine. do not delete any to those kext related to intel gma 950.......u need them to display graphics.


As for how u will be able to delete theAppleIntelFramebuffer.kext and replace it with an old 1.............u hv to get familiar with the terminal...u can use the Loepard DVD or if u r dual booting........u try to access ur hard disc from the other operating system(most likely windows) with Mac drive or something like that..........

good luck...

As for how to install with iATKOS just look at this post ..........http://forum.insanelymac.com/index.php?showtopic=83039 it explains everything u hv to do with iATKOS DVD to get it properly installed..........

Good luck

Link to comment
Share on other sites

  • 1 year later...

  • Create New...