Jump to content

10.5.2 on a Dell Optiplex GX280 SFF


1 post in this topic

Recommended Posts

I'm not really looking for too much help on this one, but since I gained a fair bit of help from these forums I thought it would be best to document what worked & didn't on this machine to help anyone else get it running. I've got one of the small form factor GX280s - service tag FL6XB1J, Pentium 4 2.8, just 512MB RAM, but with the dual DVI ATI x300 graphics card rather than using the onboard thing (is it an Intel GMA something? Not sure.) I've tried a few times before with a Kalyway disk and an earlier version of Leo4All, neither of which worked - Leo4All would lock up during installation, and Kalyway would complete installation and never boot. This time I used a Leo4All distro described as Version 3 Final.The install options I changed were minimal - I added the AC97 audio drivers and Broadcom NIC drivers from then install package, and post-installation used the .006 ATI x300 drivers from here - as the .003 and .008 drivers seemed to cause problems between the cursor and animations - the square the cursor occupied would never update, leaving a coloured box around the cursor.After installation, the NIC stopped the machine booting - I thought of going into the BIOS and disabling it, but when I was there I noticed PXE / network boot was on, which I disabled (just to onboard NIC on, no options) and then it worked fine, double plus.The Graphics don't work entirely, as animations (like switching Spaces / bringing in the dashboard) are laggy, I'm not sure if this is a GFX problem or a lack of RAM, but the x300 isn't running Quartz Extreme (yet?) so that's probably it. I'm not sure if this have ever been addressed for this card, but it would seem not from what I can gather - if anyone knows otherwise I'd love to know. I tried patching but with no luck so far, but this will continue for a while before I give up.Only other problem I ran into was the keyboard - I used this guy's custom keymaps to use a British Windows Keyboard - I needed his "Older" version - as the ' and \ were messed up on the v2.If anyone's got any questions or advice I'd love to hear it:)


[Edit] Afterthought - I could try with the on-board graphics, if they're any more likely to be QE compatible, of course..

Link to comment
Share on other sites


  • Create New...