Jump to content
InsanelyMac Forum
champro

X3100 to work without sleep trick

Recommended Posts

I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(

but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

 

Hope It works for others. just want to share it .

enjoy.

 

atthach the file in case someone may need it.

AppleSMBIOS.kext.rar

Share this post


Link to post
Share on other sites
Advertisement

I'll have a go.

 

What's your system? I'm on a Dell XPS m1330. These are notorious for having problems with x3100 whilst others have been able to make it function properly.

Share this post


Link to post
Share on other sites

By the way, are you running 10.5.2 and do you have the graphics update or are you using the stock kexts?

Share this post


Link to post
Share on other sites
I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(

but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

 

Hope It works for others. just want to share it .

enjoy.

 

atthach the file in case someone may need it.

 

I gave it a try on my 1720 and no joy. But it didn't break anything. :)

Share this post


Link to post
Share on other sites
I gave it a try on my 1720 and no joy. But it didn't break anything. :)

 

How did you get your x3100 to work on your Dell? I've been messing about with it for a few days and I've still nothing.

Share this post


Link to post
Share on other sites
How did you get your x3100 to work on your Dell? I've been messing about with it for a few days and I've still nothing.

 

QE/CI and resolution change work out of the box with iATKOS v1r2 & r3 with the only problem of the display going to sleep on the resolution change. The work around for this is setting up a hotcorner sleep display or a sleep display app to open at login. The hotcorner is needed if you manually change the resolution.

 

Once the system has been put to sleep however the display no longer goes black when the resolution is changed. This is helpful for gamers as some games will change the resolution.

 

The best solution I have found is to not shut it down I just use sleep mode.

Share this post


Link to post
Share on other sites

I used iAtkos 2.0i and my video didn't work at all after the install. Did you select the x3100 drivers? The only way I could get the system to boot was with a vanilla kernel and not drivers/patches. I'll try copying them over from the DVD and see if that helps. Did you have to do anything else? Have you done the graphics update or does that break the video?

 

Also, with the sleep corner trick, does that mean the screen always blanks after the Apple loading screen? If I load the drivers, the system will keep running, though the screen goes from blue to black. So it'll always do that, fall asleep, then come back up once I've moved the mouse?

Share this post


Link to post
Share on other sites
I used iAtkos 2.0i and my video didn't work at all after the install. Did you select the x3100 drivers? The only way I could get the system to boot was with a vanilla kernel and not drivers/patches. I'll try copying them over from the DVD and see if that helps. Did you have to do anything else? Have you done the graphics update or does that break the video?

 

Also, with the sleep corner trick, does that mean the screen always blanks after the Apple loading screen? If I load the drivers, the system will keep running, though the screen goes from blue to black. So it'll always do that, fall asleep, then come back up once I've moved the mouse?

 

Here is the guide to get it to work in iATKOS. I have no idea if it would worh on a 1330.

http://forum.insanelymac.com/index.php?showtopic=79526

 

It is a little quirky but once it installs and you get a hot corner set up for sleep display and a sleep display app to open at log on it works OK.

 

And again once the system sleeps and wakes up it works flawlessly.

 

The apple graphics update just gave me a black screen. I think if delete all of the Gma950kext before reboot it would probably work OK. I just haven't tried it because I don't want to break my install.

Share this post


Link to post
Share on other sites
Here is the guide to get it to work in iATKOS. I have no idea if it would worh on a 1330.

http://forum.insanelymac.com/index.php?showtopic=79526

 

It is a little quirky but once it installs and you get a hot corner set up for sleep display and a sleep display app to open at log on it works OK.

 

And again once the system sleeps and wakes up it works flawlessly.

 

The apple graphics update just gave me a black screen. I think if delete all of the Gma950kext before reboot it would probably work OK. I just haven't tried it because I don't want to break my install.

 

I used the sleep bit and finally got it to work. To be honest though--and I don't know if this is because it's a hackintosh--I think Vista looks much better. I wish I could compare it to a real Mac, but the font rendering seems off and the screen profile/settings were way too bright. I calibrated the monitor, though I still don't think it looks as nice.

 

Have you noticed the same or have I just not spent enough time putting everything in order?

Share this post


Link to post
Share on other sites
I used the sleep bit and finally got it to work. To be honest though--and I don't know if this is because it's a hackintosh--I think Vista looks much better. I wish I could compare it to a real Mac, but the font rendering seems off and the screen profile/settings were way too bright. I calibrated the monitor, though I still don't think it looks as nice.

 

Have you noticed the same or have I just not spent enough time putting everything in order?

 

I calibrate my display and I like it better then vista. The only thing I miss about Windows is IE7.

But I must admit that everything work in Vista.

Share this post


Link to post
Share on other sites

X3100 Without sleep trick!?

Does anyone solved this?!

 

the problem is that when I start a game (rise of nations), the screen goes black (as the sleep on startup) and I can´t wake the video during the game.

 

how can I solve this!?

could someone make this x310 video card without the sleep trick!?

 

Thanks!

Share this post


Link to post
Share on other sites
I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(

but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

 

Hope It works for others. just want to share it .

enjoy.

 

atthach the file in case someone may need it.

 

So, was anyone successfully able to boot into their Mac OSX with respective/full display settings and not having to drag their mouse to the corner or what not with this file from Champro?

 

Btw, Champro, once we have downloaded the file, you are supposed to delete the '.rar' part correct so the file name reads: "AppleSMBIOS.kext" ?

Share this post


Link to post
Share on other sites
Do you see this ?

 

 

Just read that over. Kind of confused me. I'm not usre I understand what it will do now?

 

ALso, we both have the 1525 dell laptop, have you been able to get to burn cds or read cds that you put in the disk drive?

Share this post


Link to post
Share on other sites

Hello. I have a Dell XPS M1330 with the Intel X3100 chipset. I have a fully working display without using the sleep trick. The key is DSDT editing. I downloaded a DSDT from a thread that works perfectly. The only problem I'm having now is that I can't get the system to go to sleep. All of my USB devices are detected as internal, and I don't really know what else to check. Any ideas? When I go to sleep, it wakes up instantly to a black screen, from which I can't recover without a hard reboot. Thanks.

 

If anyone wants to give my DSDT a go, let me know. I'll link it here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×