Jump to content

How to recover HFS+ error using Acronis Disk Director (The easiest way)

2 posts in this topic

Recommended Posts

I ran into the HFS+ error after installing Vista and also trying to get XP to work.


Boot Acronis Disk Director CD (I use Hiren's BootCD).

Choose Manual Mode.

Right click on OS X partition and select Advanced then select Change Type.

Scroll way down until you see 0AFh and ShagOS Swap. Select that and click OK.

Now click on Operations and then Commit or the Commit icon to get OS X partion type updated.


Reboot and voila! I got mine to work. I tried the HFS+ fix error using the terminal and that didn't work. After Vista, the partition type of OS X got changed to something different and that was why it couldn't boot.


I also use Acronis OS Selector and that too works great! Hope this helps users out there who are having same problem I had. Save you guys a ton of time and frustration.

Link to comment
Share on other sites

  • 3 weeks later...

...Didn't work for me. I'm installing it on Sony FZ190.


I installed Vista x64 first and formatted the hard drive.

During Vista install, I created 3 partitions.


OS X runs fine with the DVD in the drive... but when it's not, it gives that HFS+ error!

Link to comment
Share on other sites


  • Create New...