Jump to content

1680x1050 on GMA 950 iATKOS


5 posts in this topic

Recommended Posts

Does anyone know of a way to get 1680x1050 resolution with a GMA 950 graphics setup on a desktop installed with IATKOS? The highest widescreen resolution options are have a 1280x800 and then it just displays full screen resolutions.


I have tried replacing kext files, different install options, and I am currently running SwitchResX but it looks awful and blurry on my lcd. The LCD is a 20" with a native 1680x1050 resolution. Does anyone have any ideas?




Link to comment
Share on other sites

  • 1 year later...
Seriously.. no one has any ideas?



I got the same issue, and would be great if someone can help us PLZ !

Have GMA 950 in motheboard AsRock ConRoe 1333-667 R1.0 and I tried lots of ditros (kalyways, idenebs, iatkos...).


I got a screen with 1680x1050 res optimized (samsung 21") and GMA 950 with core image and quartz extreme working but ugly resolution (it's actually 1280x1024 but stretched).


I tried SwitchRes and boot strings but nothing working.



Thanks in advance.

Link to comment
Share on other sites

  • 2 months later...

You guys should read this post



I got GMA950 at highest solution my monitor has, which is 1920x1080 with QE/CI fully working, you can see my hardware specs at my signature


I run Leopard 10.5.6 or 10.5.8 ( sorry I do not remember exactly version ) with GMA950 at 1920x1080 QE/CI support, I used XXX v2 Leopard Install Disc, and I have found a driver for GMA950 in this forum ( don't remember exactly )


Then I've moved to Snow Leopard 10.6 with DSDT.aml, I got GMA950 1920x1080 with default driver come with retail install disc but in 32-bit only, then I upgrade to 10.6.2 and I finally got 64-bit system GMA950 1920x1080 QE/CI


Snow Leopard 10.6 only have QE/CI support for 32-bit version, you can run your system in 64-bit but no QE/CI.

Upgrade to 10.6.2 then I have QE/CI for 64-bit system

Link to comment
Share on other sites


  • Create New...