Jump to content

US Robotics USR5422


3 posts in this topic

Recommended Posts

Well, that's the usb wireless I'm trying to get working... USR5422 U.S. Robotics. In other revision, I realize that chipset is a Prism GT, not a Zydas. So down info is just for USR5423 and up.


So, in hardware info there's no chipset specification, but in Windows drivers, in .inf file I can see its a ZD1211B. With that info, and a lot of googling, I tried to install Zydas, and change key 01 in ZD1215Mac.kext (ZD1211B kext file). It seems to load successfully, but light doesn't says that, and in zydas app no Wireless USB shows...

















I've changed idProduct and idVendor with decimal numbers, and I'm sure when I connect usb it loads ZD1215Mac.kext (back in time I haven't changed permission in file, and when I connect usb an error message shows, not now with permission ok).


I tried too with ZD1211Mac.kext (ZD1211 chipset), and nothing.


I attach the kext modified, if someone has the same USB wireless and want to prove it...

Just put it into /System/Library/Extensions/ and, if necessary:


sudo chmod -R 755 /System/Library/Extensions/ZD1215Mac.kext/

sudo chown -R root:wheel /System/Library/Extensions/ZD1215Mac.kext/

Any opinion??


P.d: sorry, I haven't good English level...


Link to comment
Share on other sites


I have the same problem with my USR 5423 (maybe they are similar) but I had different results.

So...I got my powerbook G4 monday and I want to use this wireless usb key cos I have no money to buy other adapters (mac air-sfuff and co).

I add to the files u modified the dedimal before restarting during the driver install.

product: 0289 (try adding "0" first or the same I added)

vendor: 2991


At the moment my powerbook recognize the key as "USR WLAN USB 2.0" or somthing like this.

the problem is that when I try to connect to a wireless (I tried also not using DHCP and adding IP,Router,DNS in the network panel) in the ZD utility I can see just "connecting..." and no light from the adapter.

If I try yo chose "Ad-hoc" I can see "connected to...etc" and the status bars (Tx Rate 11Mbps), lights on the adapter but no internet (I know that I've to set "infrastructure").

So...I think I'm close to solve the problem but maybe I need more suggestion from experienced users (it's my 4th day I usa a mac).


Link to comment
Share on other sites

Well, that's my end. I looked your drivers, of 5423, not mine 5422. So mine chipset is Prism GT, and I doesn't found not leopard drivers, just for Tiger. For you, I just can say I had the same problem with a RT73, and I solved with static IP. Just prove it with other wireless signal, without wep/wpa encription.

Link to comment
Share on other sites


  • Create New...