Jump to content

HFS+ Partition Error (Yes, i already tried the fix)


2 posts in this topic

Recommended Posts

Hi all,


I just finished an install of 10.5.2 (much to my disbelief) using Zephyroth's AMD installer.


When I initially booted up, my computer reacted like there was no bootloader installed at all, so I restored Vista's, and then tried to use EasyBCD to add Mac. At this point, I was getting a Chain booting error. Eventually, I gave up and reinstalled, this time selecting all the bootloader options.


When I rebooted after a succesful install, I was greeted by a corrupted version of Vista's bootloader. I once again restored it using a Vista install dvd, and then got the HFS+ Partition Error. So, I checked the forums, and found that I needed to make sure that my partition was active, primary (rather than logical), and had an id of af. I converted the partition to primary, made it active, and set its id to af. None of this worked, so I tried another fix:


fdisk -u /dev/rdisk0


After I did this, I once again had a corrupted bootloader, so I once again restored, and then re-added the Mac entry to EasyBCD, and still I'm getting the same error.


I've never come this close to a full installation of Leopard, so I would really appreciate it if someone offered me some advice.


Thanks in Advance

Link to comment
Share on other sites


  • Create New...