Jump to content

First timer, no luck - any hope for AMD users?

1 post in this topic

Recommended Posts

I've been messing with computers for about 20 years and always avoided Macs due to the hardware cost. Lately I've been thinking about getting into this Hackintosh thing. Today I tried to figure it out. About 12 hours later, I've got nothing.


Here's the machine:


(I apologize for any different colors or links, I'm pasting from my Newegg order history and the editor doesn't seem to let me reset colors or remove links...)


Gigabyte GA-M61PM-S2 (onboard nic is RTL8211)

Athlon X2 4000+ (Brisbane, 2.1GHz)

EVGA 256-P2-N740-LR GeForce 8500GT 256MB 128-bit GDDR2 PCI Express x16

2GB of RAM, 500GB SATA drive


If it matters I have a 300GB PATA drive and a Sony DVD burner on the PATA channels. The 500GB SATA is the boot drive.


My initial reaction is, I'm very surprised that the OSX installer runs without any problems whatsoever (i.e. loading Darwin, what seems to be the OSX GUI, and I can drag stuff around and use the menus etc.) but once it's installed it will not boot for the life of me.


I tried to use the Kalyway 10.5.2 and also the Zepyroth 10.5.2 and I'm getting nowhere. The Zepyroth will install and then never boot (alternately giving me just a blinking cursor, or "Error loading operating system"). The Kalyway will install and then try to boot, eventually it gets to a point (using -v) where it stops at "AppleNForceATA: Found 0 units." Strangely it finds 2 first, then 1, then 0 - about six times.


On the Kalyway installer (which I used first and then tried to go back to at Zepyroth failed), I installed it first without customizing the install. The only thing that selecting (what I think are the right) options in Customize does is, the bootup messages contain hundreds of additional errors. Something about it's not creating a crash log because too many crashes are happening. It says this about 400 times and always increases the PID number by one.


I've also tried booting the Kalyway install with "-legacy," same thing.


Again it's strange to me that the installer runs without a problem. Maybe it's just "fake" OSX or something. Safe mode never works either.


I'm starting to think I am going to finally pay the price for both my computers having AMD CPUs. From what I can tell, the so-called "holy grail" of the project has been the iATKOS released, and from what I gather it simply does not work on AMD CPUs. I can kind-of understand how it might work better on Core 2 chips, but in the Windows world, it's been almost 15 years since software would work on one x86 chip and not another. But from what I could gather today, it seems that OSX is sort of an engine and the Kexts are where it's at. However, it puzzles me how the installer can read my drives and boot, and the OS it installs cannot.


If I ever become rich and famous I'll of course drop thousands and thousands of dollars on the hardware, but as a musician, I'm not only *not* rich and famous but I'm left with the choice of Vista or Linux. I've always thought I never really had a chance at my art because the time I spend works out to about 10% art and 90% IT support.


Anyway, this is my question: Is there any solid, repeatable, correct way to make OSX work on Athlons? I don't mean any disrespect at all, but I think I'd rather run Vista than have to "inject" new drivers - which on day one I won't understand anyway - into ISOs *after* having acquired the ISO, so I'm not too interested in that. I spent a lot of time in the late 90s doing that kind of stuff with Linux and I just don't have that kind of passion anymore.


I apologize if these things have been addressed before. When I search, one of two things happens. If I Google, I get thousands of links back of threads *asking* for help with no replies; if I use the search here I get told that the administrator has enabled "flood protection" and I can't search for another 20 seconds (in these cases, I haven't searched anything in 20 MINUTES). and waiting 20 seconds produces the same message.


I also apologize if it sounds like I'm looking for a quick fix, I don't mean it like that. If anything, I believe there's simply an answer I haven't found yet, and I would think that the goal of a project like this is to make it easier for those that come after you. In any event, much respect to the people who have made this happen.

Link to comment
Share on other sites


  • Create New...