Jump to content

Dell 1390 working as Airport, but wont turn on


3 posts in this topic

Recommended Posts

So I messed up my install and had to reinstall but now I cannot get my dell 1390 wireless card to turn on as airport. It works in vista and worked before the reinstall. Though it took a while to get it on.


I have tried network diagnoses and just turning it on by clicking on. None work

Link to comment
Share on other sites

  • 5 months later...

Thought I would resurect an old post because I too am having this same problem and despite a week of searching for solutions am stumped!


My setup:


Dell XPS M1710 laptop with a Dell 1390 car that I bought off e-bay.

The card works fine under windows vista with the driver from dell.


Heres what I have tried:


It shows an a 3rd party wireless under airport in System Profiler but is turned off. I click turn on (either on the menu bar at the top or through system prefs. network panel) and nothing happens. i.e. it does not turn on.


I have tried reseating the card in the pci-e slot.


I have also tried reinstalling osx86 - i had Kalyway and i now have ideneb 1.3.


I have tried the pin20 trick (covering pin 20 on the card with tape- apparently this is the pin which is used to switch it off via an external switch) but this either cause the device to not show at all or remain the with the same probelm.


I have tried the en0 en1 switching trick to no avail. probelm persists.


Have also tried selecting ipv4 to none in the advanced settings on the air port.


Tried installing the appropriate kext using osx86 tools. After this it shows as an airport extreme with lots of details but again no turning on.


Any ideas or suggestions would be fantastic!

Really am struggling here and dont want to have to buy another new wirelss card.


Thanks guys



Link to comment
Share on other sites

ok, just after posting this I finaly got it working! I installed a dual boot of vista and osx. went into visa turned it on, configured it etc, and when i restarted into osx it worked!


Any one else with this problem, try that! I guess it may work with a linux live cd or something, maybe not...



Link to comment
Share on other sites


  • Create New...