Jump to content

MiniPCIE Problems

7 posts in this topic

Recommended Posts

I've been having issues getting my lan and wifi working with every single version of OSX I've tried...


So far I've tried the following cards:

Atheros 5007x b/g card the laptop came with

Intel 4965 bgn card I upgraded to for N capabilities

Broadcom 4311 airport clone - bought with the impression it might be easier to get working

Realtek 8136 LAN built into the laptop


So far I've tried the following copies of OSX:

Brasilmac 10.5.1

hand-patched original 10.5.1 dvd

KALYWAY 10.5.1

Zephyroth 10.5.2 rev2

Tubgirl 10.4.10

IATKOS 10.4.9

IATKOS 10.4.8


Under any of these configurations I'm unable to get my LAN or WiFi to work (both pcie devices).. I've tried all the appropriate kext's, I've made sure the deviceid's were in the info.plists, I've tried patched kexts for IO80211Family.kext, IONetworkingFamily.kext, IOPCIFamily.kext, IOACPISomethingorother.kext, and probably several others.


So far, none of the cards have ever shown up under System Profiler, or in the network configuration utility, or in ifconfig, or in ioreg, or otherwise shown any hope of ever working.

I've downloaded a couple programs (Duddie's PCI manager etc) which show all the devices on your system, and each one of them correctly shows both my lan, and whatever wifi cards I have installed at the moment, as well as their deviceid's etc... but the kernel itself can't seem to find them.


In this thread and this thread people have mentioned toshiba has notoriously buggy DSDT tables in their BIOSes, and after doing a bit more digging I found this is a common issue with non-windows OS's and buggy crippled BIOSes... the linux folks have found workarounds, but I can't figure how to apply that to OSX.


Oddly enough, after me installing half a dozen kexts and fiddling with it for hours on end, I've noticed that (despite no mention of my card in ioreg) that kextstat says com.apple.driver.AirPortBrcm43xx is loaded... not sure what to make of that, considering I have no airport icon and there's nothing in network configuration (in fact, I can't click any buttons in network configuration, it's completely empty, and it sorta locks up if I try to add a location, clicking "done" does nothing.).. also /Library/SystemConfiguration/Interfaces.plist is empty... I'm wondering if skipping the "Do you already own a mac" welcome loop by touching .AppleSetupDone may have caused my network to be unconfigurable... Anyways, I digress... Does anyone have any idea how to patch the DSDT tables into the kernel?

Link to comment
Share on other sites

Bump... :hysterical:


Am I the only one who has this problem?


Has anyone had similar problems and managed to fix them?


This is driving me crazy... no internet = no point in trying to use OSX for day-to-day activities.

Link to comment
Share on other sites

Just because the kext is loaded doesn't mean it's driving the hardware. After setting up the chip there are calls into OSX that must be made to tell it about the adapter. If the driver is unable to talk to the hardware properly it will not do those things. You wind up with a loaded driver but, as far as OSX is concerned, no legit device.


In a fully supported-by-the-manufacturer configuration (i.e. a real computer from Apple) these problems just don't happen. With the crufty half-baked kexts floating around for all the "officially unsuported" hardware it's par for the course. The very definition of SNAFU.

Link to comment
Share on other sites

It depends on the kext, of course, but a common technique is to edit the Info.plist for a kext and add device identifiers that say to OSX, "Sure! I can drive that device!". That's probably what you're seeing. You wouldn't see that at all with completely supported hardware with device drivers sanctioned by Apple or the device manufacturer. That would indicate a serious problem somewhere.

Link to comment
Share on other sites

well what gets me is that somehow ioreg, system profiler etc can't find the deviceids, yet by the fact that the kext is loaded, I can tell that the kernel at least at some level sees the deviceids and knows to load that particular kext....

Link to comment
Share on other sites

ioreg should be able to see every pci device on the system. Have you tried the -p option with the IODevice plane (use "man ioreg" for the exact syntax)? Use -l too (lower case L) for expanded output.


The best tool by far is the IORegistryExplorer. It's like ioreg on steroids. You might be able to find it without having to download and install the entire Xcode package. Some of the osx releases might even include it, but I'm not sure which, if any, do.

Link to comment
Share on other sites


  • Create New...