Jump to content

ALC880 on OS X 10.4.11


1 post in this topic

Recommended Posts

Okay...My laptop (Sabio MW1) is equipped with an ALC880, which I always had problems getting to work in other OSs than Windows XP and Vista.

In Linux, the card partly worked well, but I couldn't use the minijack output plug. After months of reading the net, I found out that putting "id=lg" or something, I don't remember, to the ALSA config file resulted in the card working optimal. :whistle:


Now that's another story. My recent problem is under OS X, and I've tried to fix it for .. definitely over a year or so. I remember someone posting an AppleHDA.kext file in a thread on this forum a long time ago, and that kext gave me sound and made the card visible in system preferences, but I couldn't change the volume nor use the minijack plug. However, DiaboliK said that I should use his AppleAzaliaAudio.kext instead, so I gave that a try. Then I didn't get no sound at all, even not a visible sound card in the sound settings. :(


Then I tried several kexts (+ editing vendor ID in several kexts), but no luck at this point either. I even tried HDAPatcher, + a lot of ALC880 dumps, and that didn't help at all. I won't give up as the magical kext I once used actually gave me sound - but as said, with bugs.

Anyone having some advise or fixes that might work? I really want to get my sound working, as everything else works just fine on this laptop.



0x10ec0880 and 0x27d88086 (I think)...

Link to comment
Share on other sites


  • Create New...