Jump to content

Install issues for Shuttle SB95P v2 (Leo4All 10.5.2)


fun
 Share

1 post in this topic

Recommended Posts

Install of Leo4All 10.5.2 on Shuttle SB95P v2 hangs on "using xxxx buffer headers and xxxx cluster IO buffer headers"

 

Inspired by some chatter about ACPI errors and solutions for them, I

decided to try to swap 10.4.8 versions of AppleACPIPlatform.kext and AppleAPIC.kext

for the ones that came in the install. This led to the extensions being ignored, which is probably why the "About this Mac..." dialog

fails. Nevertheless, the system doesn't hang there and I was able to move on to the next problem.

 

The Broadcom ethernet drivers in the 10.5.2 series are hanging the boot process for basically all the install

flavors on this Shuttle (Jas/Kalyway/Leo4All, etc.). So I found the extension (buried deep inside AppleIONetworking.kext/*Plugins/), removed it, and I'm able to boot fully into the system.

 

So I'm trying to solve other problems with

 

* Ethernet

 

Neither the Broadcom built-in ethernet nor the add on PCI-E e1000 Intel card are recognized

 

Any suggestions would be welcome. Can I tinker with the AppleBCM5751.kext settings? The problem I'm having is

similar to this:

I have the AppleBCM5751 kext working, however sometimes my machine freezes during boot. The only way to get around it is to reboot, disable nic in the bios, boot into osx, reboot, enable nic in bios, and then it boots into osx working.

When it freezes during boot verbose mode shows:

AppleBCM5751Ethernet: 1 1659 setPowerLevels - returning early, have a 5721. onoff=, fpcidevice=

 

The thing is that with this Shuttle, the bios don't seem to allow me any way of turning off the onboard ethernet card, so

I can't solve it the same way. I've tried manually setting all the PCI settings (IRQs?) to "reserved" but that didn't work

either. Same setPowerLevels error.

 

* Audio

 

Realtek ALC880 audio is comatose - no input or output. This is the real deal breaker for me. I can use Firewire networking but without audio...

 

Has anyone gotten the Realtek ALC880 to work under 10.5.2 with this type of motherboard? I've tried editing the info inside the HDAController extension as per some other posts, but that just hung my system.

 

 

Hardware: Intel Pentium P4 630 CPU, Chipset: Intel Alderwood i925XE, 2x 512 MB Corsair CM2X512A-6400 DDR2-800 RAM, Sapphire Radeon X1600 Pro 256mb GDDR2 DVI / TV / VGA, Realtek ALC880(D), Broadcom NetLink Gigabit Ethernet ( BCM57xx ), SAMSUNG HD401LJ (400 GB, 7200 RPM, SATA-II)

Link to comment
Share on other sites

 Share

×
×
  • Create New...