Jump to content

Disk Cloning Nightmare


1 post in this topic

Recommended Posts

I got an install working and I cloned it from a 500GB drive to another 500GB drive, stuck that in a different computer for a friend and it works like a champ. Then I did a dd clone to a 640GB drive. The clone works fine but... I wanted to recapture that other 140 GB. I have tried just about everything. Disk Utility refuses to expand the existing partition, it also refuses to add a second partition. I tried Carbon Copy Cloner and it doesn't like the clone drive. Then I got Drive Genius, first it has a problem with internal sata drives in 10.5.2, so I hooked it up via USB dongle, and then it says, oh I see a windows partition I won't touch the drive. I think part of the problem is the drive and its clones are not MBR but are guid partition tables. And maybe the EFI partition interacts with this stuff too, dunno.


I guess I thought it would be cool to clone things, even share disk images over p2p. But it has turned into a complete fiasco, every tool I have tried fails. There is another thread where people did this for a while and also had headaches recapturing the extra space on the drive. This kind of thing is no big deal on XP (Acronis) or linux, not sure why its so problematic on hack/mac.


What now? Will try a fresh install on the new computer. Though, Disk Utility thinks this is my boot drive (its not anymore) so it won't let me erase it. I'll have to resort to some violence to erase the sucker so I can format it. "sudo dd if=/dev/random of=/dev/disk2" that oughta stop all those programs from treating that disk special. Then I'll do a fresh install, and then try hooking up my old computer to my new one over firewire and try the Migration Assistant.


OK, onto the virgin install. DVD boot failed until I disabled AHCI! System would not boot off ANY boot DVD. This is a Panasonic (identifies as MAT{censored}A) SATA DVD. Just wanted to share that in case anyone else runs into it. So I'll disable AHCI until after the install, then turn it back on.


Installing Kalyway 10.5.2 DVD. Cannot for the life of me get Disk Utility to use Master Boot Record. guid didn't do jack for me, probably caused alot of the problems above, so I'd like to try MBR.


OK lets try "Format and Make HD Bootable for Leopard". Nope. When I boot into "Format and Make HD Bootable for Leopard" it just hangs at System config file... com.apple.boot.plist... not found.

Link to comment
Share on other sites


  • Create New...