Jump to content

Kalyway 10.5.2 Kernel Panic (not not like all others)


4 posts in this topic

Recommended Posts

Hello all,


First of all, I searched this complete forum and google for a solution.


I started with Tiger, no luck getting it working correctly.

Then I downloaded 10.5.1, but not much luck getting it to work with SATA drive.

Then I read the 10.5.2 worked, so I downloaded Kalyway 10.5.2, and first install was cool.

No LAN/Audio at first, but atleast a successful boot.

Working a little bit with it, then did something wrong with permissions, tried disk utility to repair permissions, but no luck. Leopard kernel paniced on boot.


So, well I thought reinstalling and it would be fine. And that's how it looked like. This time I changed a few things in installation:

1) Deselected forcedeth driver, as I found an alternative LAN Driver (Which works for nForce 405)

2) Deselected -legacy flag, Just for testing if it works without. (Now I've manually added it to com.apple.boot.plist, but no luck, even manually entering it in Darwin doesn't get rid of the problem)


So, the problem is that Leopard boots fine. Lots of applications work correct (as far as I tested), but I got the kernel panic at two ways now:

1) When downloading something with Safari

2) When starting Firefox


I assume it's something with LAN driver, but it didn't happen in my first Kalyway installation.

It's the nForceEthernetController.kext I use.











UPDATE: I got the real error message on the screen using the debug=0x100 boot option. It's a page fault in com.nvidia.ethernet, which is the LAN driver.

Does anyone know why it gives kernel panics now, and not in my first kalyway install?

Link to comment
Share on other sites

How much RAM do you have installed? I had a successful install with 6GB of RAM, but I would get kernel panics when running iDVD or anything that took a lot of memory. I am down to 1 slot full with 2GB and it seems stable so far...might be worth a shot. I installed, reinstalled, upgraded, and did a whole bunch of software stuff before I tried the RAM.

Link to comment
Share on other sites

I'm not sure what the problem was, but I installed Kalyway 10.5.2 again, with same options as the first time, removed forcedeth.kext and installed nForceEthernetController.kext and everything went fine. No kernel panics anymore, atleast, not right now!

Link to comment
Share on other sites


  • Create New...