Jump to content

[Solved] ATI Radeon HD 2600 AGP / Quartz Extreme not working


2 posts in this topic

Recommended Posts



[EDIT: This problem has been solved. Leo4allv3 just got released and a fresh install using the ATI Radeon HD 2600 AGP driver did the trick!!! I now have QE enabled and the menus work!!!]


After countless hours of fiddling, googling and rebooting, I'd like to post my problem so the experts can get a crack at it. I'm trying to get Quartz Extreme running on my ATI Radeon HD 2600 AGP, but in the one configuration that it works, I have the problem with the white menus (when clicking on the 'apple' menu, the text doesn't appear until the split-second after clicking it away.


My configuration:


Leo4allV2 (Leopard 10.5.2, with the ATI and AMD drivers supplied by Leo4AllV2) installed on an AMD Sempron 3000+, 1.8 GHz, SSE, SSE2, SSE3, 1 GB RAM. At the moment, I boot directly from the Leo4allV2 CD, let it time out at the boot prompt, and it finds my system disk automatically. I believe, therefore, that I'm using PC EFI and Vanilla mach_kernel, but I could very well be wrong here--I'm still new to the 0Sx86 scene.


ATI Radeon HD 2600 XT, AGP, 512 MB VRAM, Device ID 0x9587


I tried both of the main HowTos for the Radeons, topics 94090 and 64269. The Triakis didn't work and the only thing that brought QE was using the ATI_Radeon_HD_2600pro_AGP_With_AGPgart_10.5.1, but like I mentioned, the menus were white. Applying the white menu fix from tinyurl.com/2q3538 didn't work--the screen freezes and corrupts during boot.


I've experimented with both the ATI drivers that came with Leo4allV2 as well as the Leopard Graphics Update 1.0 from Apple.


Obviously, the patch that gave me QE was for 10.5.1 and I hoped that in those binaries, there were no significant changes here. This is probably naive, considering the upates between 10.5.1 and 10.5.2, but I had my hopes. I'm also aware that I am using AGP and not PCI-e, but I'm guessing that this probably won't be relevant.


So where is this "white menu" bug coming from and is there any possible workaround known that will get Quarz Extreme running on this config?


With best regards and many thanks in advance,



Link to comment
Share on other sites

  • 1 month later...

  • Create New...