Jump to content

64-bit 9.2.2 kernel on a P4?

5 posts in this topic

Recommended Posts

Hi all,


I've tried a few kernels:


modbin 9.2.2 -- works fine, but 64-bit apps all run in 32-bit mode.

kabel 9.2.2 -- 64-bit apps crash.

TOH 9.2.2 -- Found something by that name on the bay. Anyway, same result as kabel.


Has anyone been able to get 64-bit working on a P4 (9.2.2)?

Are there any other kernels I should try?



Link to comment
Share on other sites

How about this:


Is there anybody with a non-vanilla 9.2.2 kernel who can run 64-Bit apps in 64-Bit?

You can find out by running the included Chess app, and checking Activity Monitor. You would see "Intel (64-Bit)" next to Chess.


I'm trying to find out if its just me..


Link to comment
Share on other sites

I might be wrong, but Pentium 4s do not support 64 bit architectures. This may explain why all Apps want to run in 32bit or why 64bit apps crash. I think Intel started 64bit support with the EM64t line of P4s and the Core2Duos. Standard Core Duos did not have 64 bit support.

Link to comment
Share on other sites

  • 3 weeks later...

I found out why it doesen't work. Apparently, 64-Bit apps require a certain SSE3 instruction which is lacking on EM64T P4s. The 9.2.0 kernels have been built to work around this problem and work fine. However, the 9.2.2 kernels do not yet account for this problem. Two possible solutions at this point seem to be

(1) stick with the old 9.2.0 kernel, with 64-bit support.

(2) stick with the 9.2.2 modbin kernel, and have everything run in 32-bit.


Many intell pentium em64t users gets "bus error" on running 64-bit apps.

Currently 64-bit apps works only on Core 2 systems.

The reason is - 64 bit version of memory copy operations in commpage require SSSE3 instruction, which is currently available only on Core 2 cpus (merom, pentium E2xxx).

To fix this, somebody need to rewrite 14 kb of sse3 optimaized code for 64-bit procs.

Link to comment
Share on other sites


  • Create New...