Jump to content

Broadcom 570x and 575x


  • Please log in to reply
934 replies to this topic

#921
albert E

albert E

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts

You're THE MAN!!!
An hour ago got my BCM5752 (pci14e4,1600) working like a charm: MAC's - OK, DHCP's - OK, 100M/1000M - OK!!!

For those, desperate Dell Latitude D620 owners, or who esle, by the chance, owns this card - attached 100% working kext.
NB! Place this kext to /System/Library/Extensions AND to the "/System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins" folder
Do not forget to DELETE existing kext, and "chown/chmod/repare perms" of course!

I'm so happy, 'coz at workplace we don't have WiFi, and at last i can use MY OWN laptop instead this terrible monster, i have here...
:P

(sorry for my english)


This kext only works on 32-bit (arch=i386).

#922
knobsi

knobsi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts

Thanks SunKi!

I works out for my network card on your base, just replace all 7b 16 with 9b 16 in binary. Info.plist also changed 167b->169b.

My card infor:

Dell Optiplex 330

Broadcom Netlink BCM5787 PCI-E Gigabit Ethernet Controller (14e4:169b)


i can confirm this way for broadcom bcm57760 (1690)
running on acer travelmate 8472TG OSX 10.6.7 !!

this is really awesome !!!
thank youu....
:-)

cheers, knobsi

#923
PmgR

PmgR

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

After a small patch I got a fully functional Broadcom BCM5755 [14e4: 167b]
That's what I did:
With the help of HexEdit I replaced all b416 -> 7b16
Replaced 0f8465010000 -> 08565010000 twice
I now have a fully functional kext from Mac OS 10.6.5 with fully operational DHCP and MAC address
Sorry for my english

EDIT: To support 64 bits had to patch 0f8422010000 -> 0f8522010000
Gigabit does not work correctly (only 32-bit)

EDIT2:
Fixed bug in the patch (jz in 32-bit code is located at the 574BD, a 64-bit - 12F78)
Total. For a fully functioning version of 32 and 64 bits at 100Mb / s and 1Gbit / s (everything works for my card) should be done only:

1. replace all - b416 -> 7b16
2. at 12F78 replace - 0f8422010000 -> 0f8522010000 - 64bit code
3. at 574BD replace - 0f8465010000 -> 0f8565010000 - 32bit code

EVERYTHING WORKS!

PS: patched corrected kext :)


GREAT STUFF! Got this working for a Dell Precision M90 running 10.6.7 retail with a BCM5752 (Vid 0x14e4 Pid 0x1600).
Based on Sunki's kext file, I replaced the "pci14e4,167b" string in the plist with "pci14e4,1600" and replaced all instances in his kext file with a hex editor from 7b 16 --> 00 16

Works perfectly both in 32 bit and 64 bit!

Enjoy.

Attached Files



#924
knobsi

knobsi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
after several requests for my modded kext for propper working bcm57760, here we go:

Attached File  AppleBCM5701Ethernet.kext.zip   219.63KB   488 downloads

put it into the plugin folder of ionetworking and checky for working :-)
would love to see if it will work on your rigs ,-)

cheers, knobsi

#925
Dragon Master

Dragon Master

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Honolulu, HI
Can anyone give me an idea of a good USB Wireless dongle to buy. The criteria that I am interested in are that it is 300Mbps Draft N, works with Snow Leopard 10.6.8 and/or 10.7, and I want it to be recognized as an Airport. If not a USB dongle, perhaps a PCI-E card for my desktop. Thanks in advance for the information everyone!!!

#926
Dragon Master

Dragon Master

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Honolulu, HI
Has anyone tried using the AftertheMac n300?

http://afterthemac.com/

Does this work with a Hack'a'Mac? Either Snow Leopard or Lion?

#927
zchef2k

zchef2k

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

GREAT STUFF! Got this working for a Dell Precision M90 running 10.6.7 retail with a BCM5752 (Vid 0x14e4 Pid 0x1600).
Based on Sunki's kext file, I replaced the "pci14e4,167b" string in the plist with "pci14e4,1600" and replaced all instances in his kext file with a hex editor from 7b 16 --> 00 16

Works perfectly both in 32 bit and 64 bit!

Enjoy.


I tried this on the vanilla 5701 kext for Lion and it didn't take. Can someone crack that nut?

PmgR, I have the exact same card as you, although lspci appends it with '(Rev 02)', if that matters.

Thanks guys.

Dragon Master, this thread has nothing to do with WiFi adapters. Head elsewhere.

Z

#928
BloodyVlad

BloodyVlad

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:Ukraine
What about Lion? Tried modofied plugin and it's recognized in Network Panel, but does not work.

#929
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Anyone here with kext for Broadcom NetXtreme BCM5752 Gigabit Ethernet PCI Express (14e4 1600) for SnowLeopard 10.6.8 or Lion 10.7.2 ??

#930
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA
This is a fix for the all zeros MAC Address
http://www.insanelym...howtopic=275174

#931
the.delro

the.delro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

GREAT STUFF! Got this working for a Dell Precision M90 running 10.6.7 retail with a BCM5752 (Vid 0x14e4 Pid 0x1600).
Based on Sunki's kext file, I replaced the "pci14e4,167b" string in the plist with "pci14e4,1600" and replaced all instances in his kext file with a hex editor from 7b 16 --> 00 16

Works perfectly both in 32 bit and 64 bit!

Enjoy.


Doesn't work for my 5752 on 10.6.8. Have you upgraded to 10.6.8 or 10.7 and got this to work? Thanks.

#932
hle500

hle500

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

after several requests for my modded kext for propper working bcm57760, here we go: Attached File  AppleBCM5701Ethernet.kext.zip   219.63KB   488 downloads put it into the plugin folder of ionetworking and checky for working :-) would love to see if it will work on your rigs ,-) cheers, knobsi


Thank you
It works on my gateway ns30 (acer travel mate mb) with broad com 57760
:-)

#933
NSquirrel

NSquirrel

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I have used 10.5.1 on my IBM T43 (2668 F5G) off and on but had never got around to enabling the net access. My thanks to posts here, specifically #187 Nisa-it Posted 14 June 2006 04:46 PM, in this tread and http://www.insanelym...ess-on-startup/


(Now to update 10.5.1...)

#934
Pave99

Pave99

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Sorry for replying in the old post, but i have Broadcom 57xx and Niresh's Maverics. Is there any drivers anymore??



#935
Tmarkr

Tmarkr

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

trying to get the ethernet on a Optiplex 740 Enhanced with a Broadcom NetXtreme 57xx gigabit controller to work, I have tried AppleBCM5751Ethernet, but still nothing .

 

ven_14E4

dev_167A







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy