Jump to content

Broadcom 570x and 575x


  • Please log in to reply
934 replies to this topic

#861
MastaG

MastaG

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ah that's too bad then, it's an Acer Aspire 7730g.
Well I'm going to see if I can get the intel wireless adapter to work then, if not I'll be installing linux instead.
Thanks for everything:)

#862
kosuhin

kosuhin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

hi to all..

Trial and report kext....for .Snow Leopard

this is only... 5784m "noob1x" modified kext .


you should get this...:

BCM5701Enet: Ethernet address 00:00:00:00:00:00
Ethernet [AppleBCM5701Ethernet]: Link up on en0, 100-Megabit, Full-duplex, No flow-control, Debug [796d,0300,0de1,0300,41e1,0000]

Give feedback about and modify it if you want........as far as i know : no crash...,reboot,shutdown....

and no support. <_<


How we can change MAC adress in kext?

#863
kosuhin

kosuhin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

hi to all..

Trial and report kext....for .Snow Leopard

this is only... 5784m "noob1x" modified kext .


you should get this...:

BCM5701Enet: Ethernet address 00:00:00:00:00:00
Ethernet [AppleBCM5701Ethernet]: Link up on en0, 100-Megabit, Full-duplex, No flow-control, Debug [796d,0300,0de1,0300,41e1,0000]

Give feedback about and modify it if you want........as far as i know : no crash...,reboot,shutdown....

and no support. :)


I tested this driver in 10.6.2
1. 32bit - work correctly after manual set MAC address
2. 64bit - don't work...kext cann't find en device((((

#864
master666

master666

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
hey folks,

I'm new here, and it's the first time i tried to install osx on my laptop (Dell XPS M1710)

The only thing that does'nt work is the LAN (and Wireless)

My ethernet adapter is named ""Broadcom BCM5750A1 NetXtreme Gigabit Ethernet Controller"

is there a version of a driver for it to work?

thanx!

#865
sandynice

sandynice

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi,
I've got an HP nc6400 with a Broadcom NetXtreme BCM5753M Gigabit Ethernet PCIe [14e4 : 16fd], do you think one of the patch could make it work ?
Thanks very much.

#866
nobb1x

nobb1x

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
  • Location:Italy
snow leopard kexts published lately only works with 5764M/5784M, and they don't work with any other broadcom card.
the only thing you can do is to take my kext published few threads ago (the 32/64bit version is preferable) and try with an hex editor to replace all 59 16 with YY XX , where XXYY is the pci id of your card.
i.e. 59 16 replaced with FD 16
this will replace the 5721 card inside the kext with your own.
then in the Info.plist change 1659 with XXYY.
i suggest to copy the kext on the desktop and load it manually with kextload,after fixing the permissions.

it may work or may not, i can't try because i only own a 5764, more your card is similar to the 5721,more are the chances it will work. (no IM pls on this, i will not reply)

#867
U377V

U377V

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
my device ID is 1600 and it's not listed here... can i modify any of these kexts...

H folks,

the next try, for all who have one of the following device-id's:

16a6
166a
1677
1648
165d
1696
165e
169d
167d


best regards
Homar...



#868
nobb1x

nobb1x

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
  • Location:Italy
do you realize that post is from 2006???? 4 years ago??? do you expect someone will reply?

#869
newgame

newgame

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I see that some people had success with the BCM5755. I have exactly the same model but the device id is slightly different: 14e4x167b instead of 14e4:1673. I'm new to all this so i need help in knowing what i would need to change from those solutions to match mine. Thanks in advance for any help.

#870
mr_Dellay

mr_Dellay

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Location:Ukraine
Hi nobb1x, are you going to release your kext updates for 10.6.3 or it will be without updates?

#871
nobb1x

nobb1x

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
  • Location:Italy
it seem the 10.6.2 works without any problem in the 10.6.3 too. i'm seeing the 10.6.3, it seem to be totally different, after 6 years Apple changed the code!!! so hacking needs to restart from the scratch ;)

edit---

lol, with the new 10.6.3 and a two bytes patch i can get automatic macaddress and full eeprom support, just the dhcp don't work and don't know why but it work flawlessy assigning manual ip. i have still to try how it work after sleep and some other stuffs (just to be sure it don't make unreversable changes to the eeprom lol) then if it is ok i'll publish here on next week.

(Still 5764M only, sorry)

Attached Files



#872
mr_Dellay

mr_Dellay

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Location:Ukraine
Oh nobb1x, can you please share your new kext.

it seem the 10.6.2 works without any problem
lol, with the new 10.6.3 and a two bytes patch i can get automatic macaddress and full eeprom support, just the dhcp don't work and don't know why but it work flawlessy assigning manual ip. i have still to try how it work after sleep and some other stuffs (just to be sure it don't make unreversable changes to the eeprom lol) then if it is ok i'll publish here on next week.

(Still 5764M only, sorry)



#873
nobb1x

nobb1x

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
  • Location:Italy
original post updated with 10.6.3 version.

#874
mr_Dellay

mr_Dellay

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Location:Ukraine
Grand merci :D you are the best!

original post updated with 10.6.3 version.



#875
Piotr Janus

Piotr Janus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi.

I tried to hex-edit nobb1x kext (newest one) to make it work with 5784M and I can't achieve it...

I've changed all values from 59 16 to 98 16 and changed the text file... And no adapter is found... Can some one who make it work can help?

Ok, the problem is with 10.6.3 kext only.

With older one (no auto-MAC) it's working great.

But making newest one work would be also nice. ;)

#876
Guest: basseed_*

Guest: basseed_*
  • Guests
With 10.6.2 I was using the (Acero?) 5784m modified kext put directly in SLE removing the IONet.. one. It was working in 32bit setting manually the MAC.

I can't find that kext anymore, I am on 10.6.3 and I can't get the card to be recognized.

Hope someone can upload that kext again?

Thanks.

#877
Guest: basseed_*

Guest: basseed_*
  • Guests

I tested this driver in 10.6.2
1. 32bit - work correctly after manual set MAC address
2. 64bit - don't work...kext cann't find en device((((

Can you confirm this kext ain't working on 10.6.3, no connection even after setting manually the MAC address.
I am using 32bit mode.

#878
Piotr Janus

Piotr Janus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I'm on 10.6.3 with older kext (prior 10.6.3) and it works in 64 bits mode with setting MAC manually.

There is no problem at all (maybe random kernel panic at start but it can be something other... like after update battery is invisible also)...

#879
ujen

ujen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
Thnx to nobb1x i got my 5761e card workin with full dhcp and MAC address.

dev id is 1680

i'm on a dell precision m6400

just install kext below

Attached Files



#880
Piotr Janus

Piotr Janus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Thx for upload. With hex-editting Your modificated kext I made it works under 64bit Snow Leo with auto-MAC finding for 5784M model. :)

Thnx to nobb1x i got my 5761e card workin with full dhcp and MAC address.

dev id is 1680

i'm on a dell precision m6400

just install kext below







1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy