Jump to content

Need help with ATI x1600pro -- am I too stupid?


  • Please log in to reply
2 replies to this topic

#1
unicursal

unicursal

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Moscow, Russia
Guys,

I've been trying to get my x1600pro (asus) to work for several days. The Natit_Uni installer's kexts for Radeon work fine and I get CI and QE, when _not_ using Natit.kext or ATINDRV.kext I'm not scared of the command line, but I do need someone to give me a step-by-step guide.

The last time I got a blank screen the log said:
Feb 14 16:39:51 localhost kernel[0]: @1,display-connect-flags=0x00000400
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,device_type=display
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting model=ATI Radeon X1600 Series
Feb 14 16:39:51 localhost kernel[0]: Natit: Starting.
Feb 14 16:39:51 localhost kernel[0]: device-id: 0x71C2
Feb 14 16:39:51 localhost kernel[0]: Natit: Found device
Feb 14 16:39:51 localhost kernel[0]: Natit: Found device nameNatit: Starting.
Feb 14 16:39:51 localhost kernel[0]: device-id: 0x71E2
Feb 14 16:39:51 localhost kernel[0]: Natit: Found device
Feb 14 16:39:51 localhost kernel[0]: Natit: Found device name
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting device_type=ATY,WormyParent
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,device_type=display
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,compatible=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,display-connect-flags=0x00000400
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,compatible=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,display-connect-flags=0x00000400
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,device_type=display
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting model=ATI Radeon X1600 Series Secondary
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting device_type=ATY,WormyParent
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,device_type=display
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,compatible=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,display-connect-flags=0x00000400
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,compatible=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,display-connect-flags=0x00000400
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @1,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,name=ATY,Wormy
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting @0,device_type=display
Feb 14 16:39:51 localhost kernel[0]: Natit: Setting model=ATI Radeon X1600 Series

My device id is 0x71c2, and i'm running a 10.4.8 JaS Intel AMD SSE2 SSE3 on a Asus P5VDC-X

#2
unicursal

unicursal

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Moscow, Russia
I manually changed the device id in the Info.plist in Natit.kext to _not_ recognize 71c4

now it says this:
Feb 14 17:57:11 localhost kernel[0]: Natit: Starting.
Feb 14 17:57:11 localhost kernel[0]: device-id: 0x71C2
Feb 14 17:57:11 localhost kernel[0]: Natit: Found device
Feb 14 17:57:11 localhost kernel[0]: Natit: Found device name
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting device_type=ATY,WormyParent
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @1,device_type=display
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @0,compatible=ATY,Wormy
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @0,display-connect-flags=0x00000400
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @1,compatible=ATY,Wormy
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @1,display-connect-flags=0x00000400
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @1,name=ATY,Wormy
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @0,name=ATY,Wormy
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting @0,device_type=display
Feb 14 17:57:11 localhost kernel[0]: Natit: Setting model=ATI Radeon X1600 Series

Sounds great, but I still get a blank screen

#3
unicursal

unicursal

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Moscow, Russia
on the other hand, if someone has a working set of kexts for radeon x1600 pro 256M on 10.4.8 and could e-mail them, i'd be grateful





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy