Jump to content

A minor grub issue[solved...sort of]


  • Please log in to reply
12 replies to this topic

#1
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
I have a dual boot Mac OSX and Linux system with Grub as the bootloader. I have OSX set as the default system to boot. So after 10 seconds, Grub automatically selects OSX to boot...the screen then displays the following:

Booting 'Mac OSX 10.4.6'

rootnoverify (hd0,0)
makeactive
chainloader +1

;) And then it just waits for me to press enter to continue.

While this is not a big deal, it is rather annoying because I have to press enter each time I want to boot into OSX. I'd rather have the system boot automatically without any interaction from me. Can anyone help?

My grub.conf:

default 0
timeout 10
splashimage=(hd0,2) /boot/grub/splash.xpm.gz

title=Mac OSX 10.4.6
rootnoverify (hd0,0)
makeactive
chainloader +1

title=Gentoo Linux 2.6.17-r8
root (hd0,2)
kernel /kernel-2,6,17-gentoo-r8 root=/dev/hda5 video=vesafb:noblank,mtrr,ywrap,1024x768-32@85



#2
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
Maybe this will help: http://forum.insanel...&...st&p=198327

#3
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
Thanks for replying...but unfortunately I've already seen that thread and tried using:

chainloader --force +1


I still got the same result. In that same thread, there was also this entry:

chainloader /chain0



Using that entry caused an error message.
I also tried appending boot to the end of my OSX grub entry, but that had no effect either. The grub manual says that the boot entry is implicit and thus unnecessary in the grub.conf.

#4
cbmkgd

cbmkgd

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,243 posts
Do you have to press Entry also to boot gentoo?

Just in case, make sure there's no tabs after the "+1". With grub.conf opened in a proper editor, press Enter just after the "+1", and try again.

Have you tried to put these in menu.lst instead? Shouldn't make a difference in principle though...

(other detail: the grub manual doesn't mention the "=" after title; again that might not be important)

#5
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
No...the Gentoo entry works just fine. No need to press enter on it.

I double checked my grub.conf file...no extraneous tabs. I used nano to edit...I hope that's proper enough for you...unless you're one of those emacs zealots :( hehehe

In Gentoo, the menu.lst is just a symlink to grub.conf, so it doen't make a difference. Also, I used the "=" after title because all examples of grub.conf in the Gentoo handbook use it. And when I do Linux, I do as the Gentoo gods command me. :D

#6
cbmkgd

cbmkgd

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,243 posts
Ok, just for fun... can you switch the order of the menu, so that gentoo is first and osx second, and see if there's still a problem? Or if the problem switched to the other. Alternatively, make the other the default.
Again, just trying to eliminate possibilities.

Oh, and btw, i'm a notepad zealot :(

#7
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
Ok, I've tried as you suggested and no success. But here's a strange twist....

On a whim, from within Linux, I started VMware and configured it to run Mac OSX on a physical partition. I configured it to use the entire drive(/dev/hda) , not just the Mac OSX partition(/dev/hda1). So when I started the virtual machine, I get my original grub menu. It boots into OSX automatically, without requiring me to press enter.

Without modification, it runs as I intend within VMware, but if I run it natively, I must press enter to continue. I'm left to conclude that my problem must be a BIOS and/or motherboard glitch.

Rammjet and cbmkgd...thank you for taking the time to read and answer my post.

#8
cbmkgd

cbmkgd

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,243 posts
Then check again the thread linked by ramjet, more spec. necrophage's post: http://forum.insanel...&...st&p=198209

So maybe try root (hd0) or rootnoverify (hd0).

Didn't know then, nor now, why this worked for him though (but he didn't have the same problem either).

#9
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
I had already seen that thread before I posted my original question.

If I use root rather than rootnoverify, I get this error message:

Filesystem type unknown, partition type 0xaf


Although there is an error message about filesystem type, it still boots...with the annoying requirement to press enter :thumbsdown_anim:

Also, I don't notice any difference whether I include --force or not to the chainloader line.

#10
cbmkgd

cbmkgd

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,243 posts
Ok, from your experience in vmware it looked like it worked when using (hd0) rather than (hd0,0).
Annoying problem indeed.

#11
zoomie

zoomie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Location:Secret Underground Lair
I'm not sure if you misread my comment about using vmware...I didn't change the grub.conf settings at all. I didn't change root (hd0,0) to root (hd0). I left the settings alone. When creating the virtual machine in VMware on a Linux host, you simply cannot use the desired partition (in this case, /dev/hda1) but rather, you must assign the entire drive (/dev/hda). Its a permissions issue that I don't quite understand, but following the ideas on the Gentoo and VMware forums, its the only workable solution I've found.

But that's all beside the point. I guess I'll just have to live with the annoyance of my original problem because it seems to be a BIOS or motherboard problem, because the it works just as intended under VMware. Maybe this weekend...if I have time, I comfirm this hypothesis by installing this hard drive onto a different motherboard.

#12
cbmkgd

cbmkgd

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,243 posts
I had misread, read too fast, sorry.
The hda1->hda make me jump too fast to the (hd0,0)->(hd0) solution the other guy had, and thought it could apply to you; I made too quick a connection, seeing the symbols but not the words.

#13
donh

donh

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
Posted Oct 10 2006, 07:00 PM
I had already seen that thread before I posted my original question.

If I use root rather than rootnoverify, I get this error message:

Filesystem type unknown, partition type 0xaf"

Seems your boot sector is not setup correctly. When you hit enter it is getting the the darwin bootloaader from somewhere else maybe your DVD. Try this to set it up. Read the whole thread befor doing it. Look at jrsdead 's posts if it doesn't come up to that.

http://forum.insanel...mp;#entry166040

It worked for me. I got errors on the bless command but I think grub doesn't need what ever bless does.

Good discusion here also.
http://forum.insanel...showtopic=29859

Don





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy