Jump to content

5.1 sound on ALC888S


  • Please log in to reply
3 replies to this topic

#1
Vustom

Vustom

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts

I'm using a modified AppleHDA.kext which makes the 2.1 sound and Mic work but I got new 5.1 speakers and I can't get them to work. There split up to 3 different outputs in the Sound preferences. I've tried joining them together as seen on some YouTube tutorials but it still only plays through far left and far right, left and right or bass and center.

I can't get them all to work at the same time. Any ideas?

i've seen this post: http://www.insanelym...applehda-audio/ but I don't understand what to do..



#2
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,266 posts
  • Gender:Male

 I don't understand what to do..

Which step is the problem?

  1. Applications/Utilities/Audio MIDI Setup/Audio Devices/+/Create Aggregate Device
  2. Select (in order)
    1. Built-in Output
    2. Built-in Line Output (1st)
    3. Built-in Line Output (2nd)
  3. Configure Speakers
    1. Multichannel
    2. 5.1 Surround
  4. Apply/Done

Screenshots: Download/View Raw, M-Realtek_ALC_AppleHDA_Screenshots.pdf.zip



#3
Vustom

Vustom

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts

I've tried this, I've setup the configuration up perfectly but it still only plays from 2 out of 6 speakers.

If anyone wants to help, I've added more system info here: http://www.insanelym...38#entry2008377



#4
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,266 posts
  • Gender:Male

I've tried this, I've setup the configuration up perfectly but it still only plays from 2 out of 6 speakers.

OS X 5.1 sound requires 5.1 source and a 5.1 player.  What source?  What player?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy