Jump to content

Force Clover to always choose Win 8.1 EFI as default boot option


  • Please log in to reply
9 replies to this topic

#1
Melvin.FoX

Melvin.FoX

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:PL

Hi!
I'm running Mavericks on my Hackintosh installed on SSD with EFI boot option with a Clover bootloader. On second SSD I have Win 8.1. Both systems are visible in Clover but Mac is primary booy device as default. Only chaning boot device in Mac settings can change to start Clover with chosed Windows, but only to next time when i start Mac OS. I won't remember about changing preferences every time I run Mac and Windows is my main work system so it is highly recomended that it shold be always main boot system. Please help :/

 

-----

I've managed to find my Windows 8.1 EFI drive type (or code) and entered it as Default Boot Volume in Boot, checked IgnoreNVRAMBoot and additionally in GUI I've added Custom Entry with Type / Other, VolumeType / Internal and Hidden checked - that prevents from doubling Windows EFI boot (hide UEFI Internal from EFI).

Everything is fine - Thread can be closed :)



#2
Melvin.FoX

Melvin.FoX

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:PL

In fact my case isn't solved yet :/ I haven't found that when I choose IgnoreNVRAMboot and choose to boot from any other device the timeout / automatic countdown doesn't shows up at all :/ It always stays at Clover boot screen and I have to press Enter to boot to Win, but I would like to make it just run by itself after eg. 5 seconds. Argh :/

------

I've found that that when using IgnoreNVRAMboot I don't have to put anything into Default Boot Volume. It will always stay at the very first option in Clover so that's not the solution I'm looking for. Waiting for some suggestion :C



#3
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 488 posts
  • Gender:Male

The IgnoreNVRAMboot option is a relatively new feature of Clover (from rev 2475 see this post at ProjectOSX) and may have some bugs.  In the past, the choice of default boot option was given the following priorities:

 

Startup pref pane (in System Preferences)>Last Booted Volume>Default Volume in config.plist.

 

I had the same problem as you in that Clover ignored the config.plist value and kept reverting to the OSX volume once it was booted...I tried with the IgnoreNVRAMboot ticked in Clover Configurator and specified default loader as the Windows bootmgfw.efi (as an alternative to specifying a default volume -refer boot options in Clover wiki)---->Windows is selected but still need to press enter to boot....

 

Probably best to post your question in the Clover general discussion thread @insanelymac or @projectOSX where the developers are usually very helpful.

 

PS

As a workaround for those mostly using Windows, if you have a uefi BIOS, you can set bootmgfw.efi as your default bootloader in BIOS---->boot Windows.  A handy free windows program, EasyUEFI, also lets you change/set the default UEFI bootloader without having to go into your BIOS.

 

When you want to boot OSX, press your boot menu key (For Gigabyte boards, this is F12, for Asus boards F8, F11 for MSI)---->choose Clover to boot---->boots into OSX.



#4
Melvin.FoX

Melvin.FoX

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:PL

fusion71au - enabling Windows Boot Manager as a main boot OS is not an option. It's just not the way I would like it should be :)

 

 

I had the same problem as you in that Clover ignored the config.plist value and kept reverting to the OSX volume once it was booted...I tried with the IgnoreNVRAMboot ticked in Clover Configurator and specified default loader as the Windows bootmgrfw.efi (as an alternative to specifying a default volume -refer boot options in Clover wiki)---->Windows is selected but still need to press enter to boot....

In fact when you enable IgnoreNVRAMboot it doesn't matter what you will put into default loader field - IgnoreNVRAMboot will always stay at first available option in Clover menu :/

I think that developers haven't figured out our case :)



#5
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 488 posts
  • Gender:Male

I fixed my problem using the latest Clover r2652 and this post from @hack.in regarding ntfs.efi.

 

In my particular case (with uefi installed Windows 7), I mistakenly omitted EFI as the Default Boot Volume (I only entered bootmgfw.efi as Default Loader).

 

To fix the problem, you need to

  • Place ntfs.efi in EFI/CLOVER/drivers64 or drivers64UEFI
  • Delete your current NVRAM settings...in terminal
sudo rm /nvram.plist
sudo nvram -c
  • Edit your config.plist, entering the Default Boot Volume and ticking IgnoreNVRAMBoot with Clover Configurator...

post-846696-0-81746200-1397977482_thumb.

  • With the correct config.plist settings, everything works as expected (including timeout countdown!)....

post-846696-0-65500100-1397977703_thumb.

 

Of course for legacy Windows, the Default Boot Volume would usually be "system reserved".



#6
tomlive

tomlive

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Bangalore, India
  • Interests:virtualisation, cloud, openstack, mobile technology, linux etc.

The above works for me. However now its not automatically timing out and booting the default Windows EFI in spite of setting the 'TimeOut' variable as 5 secs in config.plist.  Any clue ?



#7
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 488 posts
  • Gender:Male

@tomlive,

 

Do you have legacy Windows installed on an MBR drive or UEFI Windows on a GPT partitioned hard drive?  Upload your Clover boot.log (in /Library/Logs/CloverEFI) and a screenshot of the boot section of your config.plist from Clover Configurator.

 

If legacy Windows, leave out the default loader and just type "System Reserved" in the default boot volume.  Also make sure you have NTFS.efi in /EFI/Clover/drivers64.

 

If UEFI Windows, you can use the same settings as I have - Default Loader = bootmgfw.efi

                                                                                             Default Boot Volume = EFI

 

 

Edit1

The count down will be missing if it can't find the default boot volume & loader...

 

For UEFI booting, NTFS.efi should be placed in /EFI/Clover/drivers64UEFI

 

If you have the correct settings, you will see the following in your boot.log

2:931  0:006  EmuVariable InstallEmulation: EFI_ALREADY_STARTED

2:931  0:000  Searching for DefaultVolume 'EFI', DefaultLoader 'bootmgfw.efi' ...

2:931  0:000   found entry 0. 'Boot Microsoft EFI boot menu from EFI', Volume 'EFI', DevicePath 'PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0xFFFF,0x0)\HD(1,GPT,F90116FB-3615-47DF-9934-1739C9B59342,0x28,0x64000)\EFI\Microsoft\Boot\bootmgfw.efi'

2:931  0:000  EmuVariable UninstallEmulation: CloseEvent = Success, original var services restored

Edit2

It looks like you renamed \EFI\Microsoft\Boot\bootmgfw.efi--->bootmgfw-orig.efi...in your boot log

1:356  0:019  found PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,5233C178-0ACB-4C84-AD23-041285746258,0x28,0x64000)\EFI\Microsoft\Boot\bootmgfw-orig.efi

and therefore Clover can't locate the default loader!

1:847  0:000  Searching for DefaultVolume 'EFI', DefaultLoader 'bootmgfw.efi' ...
1:847  0:000  Default boot entry not found


#8
tomlive

tomlive

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Bangalore, India
  • Interests:virtualisation, cloud, openstack, mobile technology, linux etc.

@tomlive,

 

Do you have legacy Windows installed on an MBR drive or UEFI Windows on a GPT partitioned hard drive?  Upload your boot.log (in /Library/Logs/CloverEFI) and a screenshot of the boot section of your config.plist from Clover Configurator.

..

i have both Windows 8.1 and OS X 10.9.2 installed in UEFI mode ( GPT partition ) and I followed exactly your configuration . ( i.e. NTFS.efi in /EFI/Clover/drivers64,  and your Clover Configurator settings  )

Here is my relevant [boot] section in my config.plist: Also attached boot.log. Thanks in advance for your advice.

 
key>Boot</key>
<dict>
<key>Arguments</key>
<string>-gux_defer_usb2</string>
<key>DefaultVolume</key>
<string>EFI</string>
<key>DefaultLoader</key>
<string>bootmgfw.efi</string>
<key>Legacy</key>
<string>LegacyBiosDefault</string>
<key>Log</key>
<false/>
<key>IgnoreNVRAMBoot</key>
<true/>
<key>NeverHibernate</key>
<true/>
<key>Timeout</key>
<integer>5</integer>
<key>XMPDetection</key>
<string>Yes</string>
<key>Secure</key>
<false/>
</dict>

Attached Files



#9
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

Remove "bootmgfw.efi", you have to specify the full path, or don't specify at all



#10
tomlive

tomlive

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Bangalore, India
  • Interests:virtualisation, cloud, openstack, mobile technology, linux etc.

Thanks fusion71au and pokenguyen. Removing 'DefaultLoader' from config.plist worked !







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy