Jump to content

Supporto QE/CI/OGL X1600/X1800/X1900 [GUIDA]


  • Please log in to reply
31 replies to this topic

#1
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
BorisBadenov X1600/X1800/X1900 Full Support Solution

GUIDE VERSION: 0.3

Credit goes out to borisbadenov for getting the official Apple drivers to work with X1600 and X1800 cards.

For the latest info and discussion about this method, refer to the 'boris thread' here

Remember the golden rule: Your Mileage May Vary. User experience has shown:

TRADUZIONE ITALIANA DELLA GUIDA DI munky


Post Originale

- La X1600 e X1800 funzionano perfettamente
- Con la 10.4.4 e 10.4.6 potrete avere artefatti - Provate la 10.4.5 (Es. il DVD Myzar)
- Il supporto DVI varia. Alcune possono usare soltanto il segnale VGA.
- La scheda video perfettamente funzionante sulla10.4.6 la ASUS X1600XT Silent
- Il supporto per il DualDisplay per ora non funziona ma stiamo lavorando
- Schede video su schede madri con supporto SLI (due schede in parallelo) potrebbero funzionare con questa soluzione.

Nota: avete bisogno di un'installazione 10.4.4, 10.4.5 o 10.4.6 e di una scheda di X1600 o X1800-based. Nelle successive versioni 10.4.7 e 10.4.8 ci sono ancora problemi.
Per ovviare al problema potete installare il driver del tutto automatico che trovate in questo sito
LinkDriver questo driver funziona anche con la X1900

Ps. Il driver funziona in tutte le versioni...anche sulla 10.4.8

Nota: Se avete una Mobility X1600 con id 71c5 anche se installate il driver dovete modificare una stringa che trovate un p pi gi quella di ATY,WORMY con Display

Come applicare la patch:

1) (Se volete!) Rimuovere tutti i kext GeForce e ATIRadeon da /System/Library/Extensions eccetto:

ATIRadeonX1000.kext
ATIRadeonX1000GA.plugin
ATIRadeonX10000GLDriver.bundle
ATIRadeonX1000VADriver.bundle
ATINDRV.kext

2) Aprite il terminale e digitate:

sudo -s (inserite la vostra psw)
nano /System/Library/Extensions/ATINDRV.kext/Contents/Info.plist


Cercate questa stringa:

<string>IONDRVDevice</string>


e modificatela cos:
<string>IOPCIDevice</string>

Adesso cercate questa stringa:
<string>ATY,Wormy</string>


e modificatela cos:

<string>display</string>

Nota: Se avete una Mobility Radeon X1600 con id 71c5 dovete lasciare ATY,WORMY

Prenete Ctrl + o per salvare Ctrl + x per uscire.

Andate nel men 'Apple', selezionate 'Informazioni su questo mac' 'Pi Informazioni' per aprire System Profiler. Selezionate il tab 'Grafica/Monitor' Guardate il vostro Vendor ID e Product ID e scrivetevelo da qualche parte.
Es.

Tipo:	Controller compatibile con VGA
  Bus:	PCIe
  Slot:	PCI
  VRAM (totale):	256 MB
  Fornitore:	ATI (0x1002) <------Vendor ID
  ID dispositivo:	0x71c2 <-----Product ID
  ID revisione:	0x0000
  Monitor:
Monitor VGA:
  Risoluzione:	1280 x 960 @ 60 Hz
  Profondit:	Colore 32-bit
  Core Image:	Supportato
  Monitor principale:	S
  Mirror:	Spento
  Online:	S
  Quartz Extreme:	Supportato
  Rotazione:	Supportato

Adesso ritornate al terminale e digitate:
nano /System/Library/Extensions/ATIRadeonX1000.kext/Contents/Info.plist


Cercate la stringa che contiene 'IOPCIMatch'. Nella linea successiva dovete mettere il vostro Vendor e Product ID. Esempio, il vostro vendor ID 1002, e il vostro device ID 71c2. dovete combinare la stringa in questo modo 0x71c21002 (dove 0x il valore base hex quindi lasciatelo cos).

<string>0x71c21002</string>


Ctrl + o per salvare ctrl+x per uscire.

Adesso digitate:

nano /System/Library/Extensions/ATIRadeonX1000GA.plugin/Contents/Info.plist


Cercate queste due stringhe e modificate con il vostro vendo e device id:
Nel caso di sopra la stringa era: 0x71c21002
La modificheremo cos...
<key>100271c2-0000-0000-0000-000a27898d3e</key>
<string>100271c2-0000-0000-0000-000a27898d3e</string>

Nota fate attenzione perch invertita stavolta quindi: 100271c2 e non 71c21002).

Per salvare sempre CTRL+O e per uscire CTRL+X

Adesso digitate:

rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache
diskutil repairPermissions /


Riavviate e andate nella sezione in System Profller Grafica/Monitor se tutto sar attivo come in questo esempio avrete abilitato QE CI e OpenGL

Monitor:

  Tipo:	Controller compatibile con VGA
  Bus:	PCIe
  Slot:	PCI
  VRAM (totale):	256 MB
  Fornitore:	ATI (0x1002)
  ID dispositivo:	0x71c2
  ID revisione:	0x0000
  Monitor:
Monitor VGA:
  Risoluzione:	1280 x 960 @ 60 Hz
  Profondit:	Colore 32-bit
  Core Image:	Supportato
  Monitor principale:	S
  Mirror:	Spento
  Online:	S
  Quartz Extreme:	Supportato
  Rotazione:	Supportato

Note:
Lo StandBy del monitor funziona solo se mettete il vostro monitor con un adattatore DVI/VGA nell'ingresso DVI almeno nel mio caso funziona solo cos...
Questa procedura nel mio caso ha funzionato solo in un'istallazione 10.4.5 nelle successive non ho avuto successo a meno di installare il driver automatico.

Buon lavoro.

#2
lord_muad_dib

lord_muad_dib

    InsanelyMacaholic

  • Retired
  • 3,398 posts
  • Gender:Male
  • Location:italy
molto bene fratello! speriamo che tutte ste guide vengano lette!

#3
sirioo

sirioo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
ma se nn sbaglio tutto cio e solo x schede agp?

io s enn ricordo male installai quel driver sulla mia x1600 pci ma si impallo tutto...

#4
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Se avessi letto bene non specificato...anzi tutta la guida basata su PCI. Poi ci sono varie specifiche per installarla bene e farla funzionare di impallarsi si impalla per altri fattori.

#5
sirioo

sirioo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
ma tu consigli piu il driver dirittamente oppure fare tutta la procedura?

#6
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
La procedura...le cose fatte da soli risultano essere sempre le migliori. A me il driver dava molti problemi.

#7
sirioo

sirioo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
a me basta vedere il mio note che nn parte piu...sia chiaro sexmachine che io
nn metto in dubbio la tua professionalita' e quello che dico nn e riferito a te...ma io sconsiglio chi ha una x1600 pci a mettere direttamente i driver come dic eil link xche il note al riavvio nn va'..ed ora devo rimettere tutto da capo...grazie cmq x la tua disponibilita...

#8
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Ho scoperto l'arcano problema della Mobility x1600, si deve modificare il file che si modifica con la string display e ritornare ad ATY,WORMY.

Tutto questo puoi farlo anche al boot premendo F8 e digitando
-s -v -x
dopo
sh /etc/rc

e poi continui la guida...


Apri il file ATINDRV.kext per modificarlo
sudo -s (inserisci la spw)
nano /System/Library/Extensions/ATINDRV.kext/Contents/Info.plist

cerca questa stringa:

<string>display</string>

e modificala cos:

<string>ATY,Wormy</string>

cancella i file Extensions.mkext ed Extensions.kextcache

rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache

ripara i permessi con

diskutil repairpermissions /

Adesso riavvia.

Fra poco lo aggiunger alla guida.

#9
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
salve a tutti!

sto impazzendo con la borisbadenoc patch e la mia scheda grafica!!

il mio sistema:

amd athlon64x2 4600+
2 gb ram
hd PATA 80gb
SAPPHIRE RADEON X1800 xt 512MB
mobo : PC-A9RD480Adv dell sapphire con chipset ati xpress 200

ora: ho installato mac osx86 JAS 10.4.7 e tutto va abbastanza bene a parte l'audio (integrated realtek ALC880) e la scheda video. In modalit VESA nessun problema , ma se provo ad installare la patch borisbadenov (sia quella che presente nel dvd, sia via internet -->3.3) il sistema va in boot tranquillo, poi all'ultima fase "login window started" non entra nell'ambiente grafico e rimane nella schermata nera con le scritte...credo che il sistema si avvi normalmente e non vada l'interfaccia grafica...boh...

la mia scheda DEVE funzionare con la patch o ha un problema?

qualcuno sa se con la mia scheda madre l'audio attivabile (per lo meno in output)?

grazie ragazzi e buona smanettata

#10
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Per la scheda audio non ne parlare qu che non ha niente a che vedere.
Per la tua scheda video la XT c' qualcosa di diverso e se fai una ricerca la trovi...Prova il link che ho dato a sirioo modifica e lascia ATY, WORMY
In ogni caso i driver pkg a mio parere non sono eccelssi. Io farei il manuale su una 10.4.5 e poi aggiornerei...a me sembra andata una favola.

#11
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Per la scheda audio non ne parlare qu che non ha niente a che vedere.
Per la tua scheda video la XT c' qualcosa di diverso e se fai una ricerca la trovi...Prova il link che ho dato a sirioo modifica e lascia ATY, WORMY
In ogni caso i driver pkg a mio parere non sono eccelssi. Io farei il manuale su una 10.4.5 e poi aggiornerei...a me sembra andata una favola.


grazie sax per il supporto...ora inizio a vederci pi chiaro...nel forum di borisbadenov una persona mi ha detto che anche lei con la stessa scheda ha dei problemi...che sfiga oh...!!

cmq: ho fatto la procedura manuale lasciando ATY,WORMY, ma dopo la comparsa del puntatore (che per un attimo mi ha fatto saltare dalla sedia per la gioia) compare una schermata che tutta un casino, con colori sballati etc...Se invece faccio la procedura completa (con anche display) , l'ambiente grafico non parte nemmeno...sob

sto installando una versione del' OS pi vecchia adesso (HOT ISO 10.4.6) e vediamo se funziona..

Nel forum borisbadenov c' scritto di provare la 10.4.5 Myazar disc...secondo te valida? e poi (ultima domanda ;)) : per aggiornare l'OS almeno alla 10.4.7 ci sono problemi?

grazie e scusa per la tempesta di domande!

ciao

#12
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
niente da fare...nemmeno con la 10.4.6

a sto punto non c' niente da fare... :compress: ;) ;)

#13
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Allora io quando formatto faccio sempre cos:
installo una qualsiasi versione del Mac OS 10.4.5 metto tutti i driver che mi interessano tra cui naturalmente quelli video che sono di un mare di tempo f...
Mi spiego meglio mi tengo salvati i kext ATIRadeonX1000 gi modificati (con il metodo Boris) cos devo solo sostituirli e caricarli...
Se questi stessi kext li metto su una 10.4.7 non funzionano...perch ricchiamano certi Frameworks che ancora devo scoprire.
Quindi io li installo su una 10.4.5 e poi aggiorno tranquillamente senza nessun problema... strano ma cos per via dei frameworks. Stessi driver messi su una 10.4.7 non funzionano se li metti sulla 10.4.5 e poi aggiorni funzionano.

Comunque nella guida io avevo congiliato alla fine di metterli su una 10.4.5

Vedrai se li installi come qualsiasi patch sulla 10.4.5 e poi aggiorni alla 10.4.7 o 4.8 non avrai mai nessun problema. La 10.4.5 per le modifiche una bomba...

#14
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Allora io quando formatto faccio sempre cos:
installo una qualsiasi versione del Mac OS 10.4.5 metto tutti i driver che mi interessano tra cui naturalmente quelli video che sono di un mare di tempo f...
Mi spiego meglio mi tengo salvati i kext ATIRadeonX1000 gi modificati (con il metodo Boris) cos devo solo sostituirli e caricarli...
Se questi stessi kext li metto su una 10.4.7 non funzionano...perch ricchiamano certi Frameworks che ancora devo scoprire.
Quindi io li installo su una 10.4.5 e poi aggiorno tranquillamente senza nessun problema... strano ma cos per via dei frameworks. Stessi driver messi su una 10.4.7 non funzionano se li metti sulla 10.4.5 e poi aggiorni funzionano.

Comunque nella guida io avevo congiliato alla fine di metterli su una 10.4.5

Vedrai se li installi come qualsiasi patch sulla 10.4.5 e poi aggiorni alla 10.4.7 o 4.8 non avrai mai nessun problema. La 10.4.5 per le modifiche una bomba...


grazie mille! si adesso che ci penso mi ricordo di aver letto nel tuo post della 10.4.5 !.... devo solo trovarla in rete.... in iso hunt non la trovo...(qualche suggerimento?....)

p.s. per gli aggiornamenti devo scaricare i file da qualche parte?

p.p.s. scusa sono un po newbie...

#15
indiffident

indiffident

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Location:Italy
RADEON x1600PRO 256MB della GCUBE.
ho installato la 10.4.6 e poi questi fantomatici driver...
l'osx si impalla, si avvia, ma resta fisso in schermata blu con una risoluzione + alta della 1024x768.

mah...
idee per risolvere?

grazie.

HW: athlon 3200+ (64bit/ss2/ss3)
1GM RAM 400mhz
asrock 939S56-M (sis756)
radeon x1600pro (gcube)

#16
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Fantomatici non sono...Io ho provato l'installer e funziona benissimo sulla 10.4.7...sulla 10.4.6 no lo s (ma nel post originale nessuno ha avuto problemi). Leggete prima di fare le prove..."10.4.5" i vostri dvd sono quasi tutti di base 10.4.5 con un update a 10.4.7 o 10.4.6...Non chiedete dove trovare gli update e le varie versioni. Nei maggiori siti di torrent ci sono e google sempre vostro amico.

Prova a cercare qualcosa sulle gcube magari hanno qualcosa di diverso.

#17
indiffident

indiffident

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Location:Italy
ora funziona, ma non sulla 10.4.6, ho profato sulla 10.4.4 facendo la procedura via terminal e funziona perfettamente.

grazie.

#18
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Mi f piacere...Adesso comunque puoi aggiornare a qualsiasi versione e non avrai problemi.
Se non vi dispiace dovrei fare un po di pulizia cerchiamo di manetenere pulita questa bella guida e se volete possiamo aggiorniamo al meglio.

Entro 24 ore molti post saranno eliminati...

#19
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
aiuto...ormai le ho provate tutte...ma questa maledettissima x1800 XT non vuole funzionare!!! ma perch!?!?

mi manca solo la 10.4.4 e poi non avr pi nessuna speranza...sob...me tapino...

scusate lo sfogo, ma qui in giro sembra che questa scheda ce l'abbia solo il sottoscritto e un altro sfigato coem me....

che il vesa sia con me....:blink:

#20
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Guarda non siete assolutamente due sfigati proprio perch quella scheda nel forum ce l'hanno tantissime persone che fanno test, oltretutto risultata la migliore per i game quindi il problema vostro non della scheda o del sistema.
Hai provato manualmente? hai provato i driver messi su una 10.4.5? ci sono tante prove da fare, non puoi dire di averle provate tutte perch altrimenti avreesti gi la tua scheda funzionante.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy