Jump to content

HP 630 i3 380m AppleIntelCPUPowerManagement.kext

- - - - -

  • Please log in to reply
8 replies to this topic

#1
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Salve a tutti. 

Ho installato sul mio hp 630 con processore i3 380m (prima generazione) e scheda network combo ML 10.8.4.

TUTTO WORKA ALLA GRANDE! QE/CI inclusi.

Solo un piccolo problema, non riesco a disabilitare NullCpuPowerManagement.kext. Appena lo levo ottengo KP!

Spero che qualcuno possa aiutarmi.... il pc oscilla come moltiplicatore tra 7 e 19 senza intermezzi. In stand-by sta a 55°C ma se faccio qualcosa sale oltre gli 80!.....grazie in anticipo!



#2
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 305 posts
  • Gender:Male
  • Location:Italy

Ciao Lirz,

una volta tolto il NullCpuPowerManagement.kext devi caricare il AppleIntelCPUPowerManagement patchato, lo puoi prelevare anche dal vaso di pandora...

ricordati di riparare i permessi.... ciao

Per un i3 della tua generazione ML è pesantino, Hai attivato i CStates e i PStates? ma in effetti 80° sono tantini!!! Ma la fan della cpu gira regolarmente o a un certo punto frulla a tutta?



#3
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

La ventola attacca a frullare a tutta, quindi almeno questo funziona. ma appleintelcpupowermanagement parcato non era per gil ivy bridge? Grazie mille per la risposta......


Poi ho attivato CSX PSX DropSSDT SystemIO in tutte le combinazioni per vedere cambiamenti.... attualmente sono tutti e 4 attivati. Infine c'è da dire che upgrado sempre con l'ultimo bootloader


anceh in pandora è per ivy bridge e sandy bridge.... il mio è arrandale



#4
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

ok.... non so se è diversa la patch ma dal vaso di pandora funziona. mi ha fatto KP la prima volta e poi per magia tutto ok......tranne il fatto che mi ha smesso di funzionare il bluetooth......bhè... farò altri tentativi in futuro per quello.... INTANTO GRAZIE!!



#5
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Anche il bluetooth funziona abilitando CSX PSX e DropSSDT........Perfect.......il KP me lo continua a fare se avvio in verboose mode......ma non se avvio normalmente..... idea del perché?



#6
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 305 posts
  • Gender:Male
  • Location:Italy

Ciao Lirz,

scusa il ritardo... te lo avevo suggerito perché anche se non è specifico (L'AppleIntelCPU...) per l'Arrandale cmq mi aveva dato delle buone soddisfazioni... su un vecchio laptop con 2 duo...

 

Posta il kp. che gli do un occhio!!!



#7
>Federico<

>Federico<

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts
  • Gender:Male

80° alcune volte è normale per queste "nuove" cpu, la mia (i3 2348m) ha un limite di 105°, anche se finora la temperatura massima è stata 65-69°



#8
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Punto della situazione: 
Ora tutto funziona, apparte il KP del verbose che va risolto altrimenti ho paura di ritrovarmelo anche nell'avvio normale dopo qualche -f o robe simili, Il moltiplicatore ora varia con valori intermedi. So tuttavia che volendo un downclock basterebbe attivare solo i c2 states e c3 states e non mi arriverebbe più a x19.... in questo modo potrei diminuire la temperatura ma ciò non funziona, sembra che toccare quei settaggi dal bootloader non abbia alcun effetto.....ho disabilitato generate px e cx e dropssdt.... senza notare alcuna differenza.
le temp rimangono tuttavia invariate e salgono senza alcuna differenza rispetto a quando c'era nulllcpupowermanagement, forse qualche miglioramento minimo. Inoltre sembra non avere alcun effetto avviare con busratio=18 (default è 19). sale lo stesso a x19.......nel post successivo intanto riporto il kernel panic ricevuto che intanto ha la priorità sul resto.....grazie a tutti!


https://docs.google....dit?usp=sharing
a questo link c'è la foto, avvio in verboose mode..... senza il verboose il pc si avvia normalmente



#9
Lirz

Lirz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

comunque non ci sono stati più picchi di calore.....se uso cpu stress sale subito sopra gli 80 ma nel comune utilizzo difficilmente supera i 70.... può andare, ma il perchè faccia il kernel panic col verbose mode rimane un mistero.....


è avvenuto comunque in correlazione al fatto che ho levato nullcpupowermanagement e quindi appleintelcpupowermanagement ora funziona. quindi dipende da appleintelcpupowermanagement il KP







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy