Jump to content

T61 - Only displays left side of screen


  • Please log in to reply
1 reply to this topic

#1
dave q

dave q

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

My T61 (8896-CTO) is only displaying the left side of the screen streched, and I've been pulling my hair out trying to resolve the issue. Everything else on the T61 works perfect, sleep, audio, even QE...

I originally wanted to install 10.7.4 using this guide --> http://www.insanelym...vot61-7661-cto/ however the only way I can get to the installer is by using tony's USB installer, and as soon as I follow the rest of the guide system won't get past "waiting for DSMOS" no matter what I try, or what boot loader I use, or com.apple.boot.plist settings.

So because I've found SL to work great on previous system's, I went with it. I used iHack for the installer and the boot loader, and then I used the Kext files from that 10.7.4 guide and his Sleep DSDT fix. My hardware specs are pretty much exact to what HUSABER uses in that guide, same CPU, Athero's card etc... the big difference in that I have the 4:3 LCD 1400x1050. I'm using his DSDT because sleep works + lid close sleep. During the iHack boot loader screen, and the Apple logo screen, the resolution is full 1400x1050, but the second it enter's OSX it cuts to half screen and stretched to fill the screen, although it still reports 1400x1050 as in the pic. QE still works as I've tested that, the X3100 is fully recognized, and everything still works as should... just this half screen issue. Brightness controls work perfect using x3100FB fix posted in same thread.

I would really appreciate any guidance or help anyone can give, thanks in advance. Here is the DSDT I'm using, as well the SMBIOS and com.apple.boot.plist I'm on 10.6.3 no updates yet.

see pic below.

DSDT I'm using --> http://www.insanelym...ttach_id=113718

My SMBIOS.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...rtyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>10/10/2010</string>
<key>SMbiosversion</key>
<string>MBA41.88Z.00BB.B00.0712201139</string>
<key>SMcputype</key>
<string>769</string>
<key>SMexternalclock</key>
<string>167</string>
<key>SMfamily</key>
<string>MacBook Air</string>
<key>SMmanufacter</key>
<string>Apple.inc</string>
<key>SMmaximalclock</key>
<string>2200</string>
<key>SMmemmanufacter_1</key>
<string>PRINCETON</string>
<key>SMmemmanufacter_2</key>
<string>NANYA</string>
<key>SMmempart_1</key>
<string>66-1122831E</string>
<key>SMmempart_2</key>
<string>DE8200</string>
<key>SMmemserial_1</key>
<string>4QY7734-HY</string>
<key>SMmemserial_2</key>
<string>KN2GB-0311</string>
<key>SMmemspeed</key>
<string>667</string>
<key>SMmemtype</key>
<string>19</string>
<key>SMproductname</key>
<string>MacBookAir4,1</string>
<key>SMserial</key>
<string>C0050ZFCJ5G</string>
<key>SMsystemversion</key>
<string>1.30f3</string>
</dict>
</plist>

My com.apple.Boot.plist



<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...rtyList-1.0.dtd">
<plist version="1.0">
<dict>
 
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>PciRoot</key>
<string>1</string>
<key>RestartFix</key>
<string>Yes</string>
<key>SMBIOS</key>
<string>/Extra/smbios.plist</string>
<key>SystemID</key>
<string>a84eca01-4a86-11cb-bdbc-c0991c38092d</string>
<key>Theme</key>
<string>Default</string>
<key>Wait</key>
<string>Yes</string>
<key>arch</key>
<string>i386</string>
<key>system-type</key>
<string>2</string>
</dict>
</plist>

I took this as a screen shot, but it's actually stretched to fill my screen, looks interlaced.

2q1ayk4.jpg



#2
dave q

dave q

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

For anyone else with this issue, this fixed my problem --> http://www.projectos...p?showtopic=763







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy