Jump to content

Microphone

microphone external midi sound input

  • Please log in to reply
5 replies to this topic

#1
pashoni

pashoni

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
Hello hackintosh community.

There is only one step dividing me from having fully functional hackintosh.
The only problem is my external microphone.
(In-build microphone doesn't work for quite a while now (it is broken and stopped working over night), so I've managed to find the external one which is working great on Windows.)
The problem with Mountain Lion is that i have to speak directly in my mic, almost touching it with my mouth.
Even that way I can only hear myself through speakers, but when I open up Skype, microphone doesn't record at all, and I can't hear myself in test call, even if I speak directly to it.
My Skype settings are fine, I've triple check it :)
Is there anyone who had some similar problem, and solved this issue?

Cheers


I'm trying to get this mic working (Feinier FE-269)

Posted Image

#2
3.14r2

3.14r2

    The Round One

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,333 posts
  • Location:Molvania
This might be a stupid question, but have you tried adjusting the microphone volume? How did you made the sound work and what type of sound card you have?

#3
pashoni

pashoni

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
I've adjusted mic volume.
I tried to change VoodooHDA plist kext and my microphone is working slightly better, but it's only a small improvement.
I've boosted mic entry to 100 and pretty much don't know what could I do more.

I'm using Realtek Alc272

#4
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 401 posts
  • Gender:Male
I think I talked to you about this, my computer uses ALC272X and computer also includes built in microphone. It works, but I use a headset because quality is better. Maybe purchase a headset instead?

As far as improving your Feinier FE-269 microphone, open System Preferences, then VoodooHDA preferences.

You need to disable the internal microphone. I had to do that in order for my headset microphone to work properly or else both microphones overlap and cause problems. Select Microphone ATAPI from the drop down menu and lower Recording Level and Input Gain all the way to zero (move slider all the way to left).

Attached File  VoodooHDA.png   99.17KB   9 downloads

Then select Microphone (Pink Left) from drop down menu and adjust both Recording Level and Mic Level until you are satisfied with the results.

Attached File  VoodooHDA2.png   99.36KB   6 downloads

That's it. Sometimes it may reset so you may have to do this again. Happened to me a couple of times. Just remember to pick Microphone (Pink Left) in certain applications so that the correct microphone is in use. If this still doesn't improve results, then I'm not sure if the microphone is faulty.

#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,074 posts
  • Gender:Male
  • Interests:AKern@RampageDev.com
Are you using AppleHDA or VoodooHDA?

#6
pashoni

pashoni

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
I'm using VoodooHDA.
I can claim that microphone isn't faulty, because it's working fine in windows.

Thanks for your answers.
I'll check if there will be any changes with changing voodoohda prefs.


EDIT:
Thank you so much for your help.
I've managed to get it working by changing values and muting internal mic.
It's not perfect, but definitely bearable and enough for Skype.

Cheers





Also tagged with one or more of these keywords: microphone, external, midi, sound, input


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy