Jump to content

ASUS k53SD UEFI BOOT can't boot with efi

efi uefi asus boot clover

  • Please log in to reply
4 replies to this topic

#1
GoGetIt

GoGetIt

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
hello everybody!
probably I write in the wrong thread I shouldn't write but I'm newbie in this forum.
well. My question.
I just installed OSXML 10.8.2 from retail and now I have a difficulty with installing clover.
well.
to install os x I used boot disk utility by CVAD. I had the whole selection of kexts i need and now I writing with my system. but still the question.
clover is pretty nice bootloader which supports uefi boot. my notebook supports uefi boot.
but I cant install it on my system!
well. I format whole my hdd and let osx format as it wants. it supports only guid partition table, so I selected the 5 partitions scheme set it to install. then I deleted partitions I dont need (I wanna make a triple boot) so now my partition table looks like...


/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *500.1 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_HFS OSXMLion 120.0 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
4: Microsoft Basic Data OS 200.0 GB disk0s4


and I have no clue how to boot clover from the efi partition using uefi.

bios is american megatrands v2.01 or something. uefi boot is enabled.

the difference between type of loading clover is my second hdd is mbr and partition with clover is set as bootable. here is gpt table. I read the Dmazar manual how to uefi boot with clover
but my laptop don't want to boot up.
awful! anyways, I need your help. probably asus need another efi partition config's or just cant boot from guid device( without fake mbr trick or something...) or can only uefi boot with usb devices... still I don't know! I need your help!

just add: to boot my mac system I use my external hard drive (an installation media. clover can boot already installed os x from primary hard drive) and it doesn't suit me.
and without installed loader I can't make my old windows (os partition) I dumped support efi boot (If I'd install windows first hardly I can install os x then) also I cant find any documentation about uefi boot (and how to realize it) on asus official website...

#2
GoGetIt

GoGetIt

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
cant delete topic but -- I found a "part" of solution. didnt read dmazar documentation enough accurate.
now I can load efi shell. the solution:


newfs_msdos -F32 -b 1024 -v UEFI /dev/disk0s1


now I just need to setup clover right and find the way to make a right boot option. bcfg is not work. dont know y.

probably because of manufacturer's restriction in uefi -- kinda I can boot only from /efi/asus. read this in uefi learning center.

#3
GoGetIt

GoGetIt

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
well. I found the solution. just need to create a boot option with complete path to boot file. f.e. \efi\boot\bootx64.efi

#4
alcarin

alcarin

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi there, GoGetIt.

I have the same laptop, and I'd love to be able to boot ML with UEFI. Could you please post your config.plist for the Clover and your DSDT and SSDT if you use any? Also which version of Clover you're using? Thank you!



#5
joe_black

joe_black

    h4ck1nt0sh3r

  • Members
  • PipPipPip
  • 139 posts
  • Gender:Male

I would like a solution for my X501A as well. Boot issues with anything except Snow Leopard because of this strange BIOS.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy